2

I have three computers in the network.

One of them was Windows 8.1 and recently upgraded to Windows 10.

When this computer is turned on and it connects to internet, most times it causes router to start resetting itself constantly: all router lights off, then they come on until it connects, a few seconds afterwards, the process starts again and so on. Sometimes this is resolved by rebooting the Windows 10 computer and then it works well and router stays connected. But sometimes, it cannot be used because router starts resetting and nobody can have internet access.

When this computer is off, the router works ok.

Any ideas on how to fix this will be really appreciated. The computer had no issues when it had Windows 8.1

Thanks.

EDIT:

As suggested by CBHacking in comments below, we installed WireShark. The Windows 10 computer has lots of ARP requests like "Who has 10.0.0.2? Tell 10.0.0.7". IP 10.0.0.2 is always the router. Then, another thing that looks strange is that there are many "Browser" protocol requests, sent to IP 10.0.0.255. Don't know why to that IP address and this looks like a suspect. These requests read "Request Announcement COMPUTERNAME", or "Browser Election Request", or Request Announcement WORKGROUP<1d>.

Wireshark running on a Windows 7 computer on the same network is not showing these requests. The Windows 10 one looks like it is mad making lots of Browser requests. No device has IP 10.0.0.255 where it sends these messages.

Any ideas on what these are, and how we could stop them? Is this 10.0.0.255 IP address something that is misconfigured?

Thanks for any help.

  • What is the make and model of the router? What firmware is it running? Also, have you tried disabling Windows 10 clustering update "feature"? – David Schwartz Sep 10 '15 at 1:03
  • The router is a ZyXEL P-660HW-T1 v3, provided by my ADSL provider. Not sure how to get the firmware it is running. I cannot access the router configuration, only the ADSL provider support people have the password. I'll verify the clustering update. Thanks. – Vero Sep 10 '15 at 2:30
  • Then they need to figure out why their router that they manage is rebooting. If you can't even access the router, your odds of troubleshooting it are low. But you can try disabling features that might stress the router as a workaround. – David Schwartz Sep 10 '15 at 2:44
4

A network device flat out should not be able to do that to a router. It's a security vulnerability if you can Denial-of-Service an entire network and bring down the router just by connecting to it. Home routers tend to be hilariously insecure, and probably were only tested against common machine configurations when it was built rather than actually built to be resilient or even to fully support standards.

It's probably worth checking for an update to your Win10 box's network drivers, just in case that makes the problem go away. (I wouldn't say "solves" it, because a router like that is still buggy, but that might make it usable.) If that doesn't work, you'll need to fix the router.

The first place I'd look for a fix is an update to your router. From your Win8.1 machine (with the Win10 machine off or disconnected, to reduce the risk of the router spontaneously crashing) go to the router's configuration page and look for a firmware update. The router may have a built-in update feature, or you may need to go to the manufacturer's website and look for a downloadable firmware update. Don't be shocked if there isn't one, though; home router OEMs are not well regarded for their post-release support.

The next step is to check whether the router is still under some kind of warranty. If it's provided by your ISP or similar, I suggest calling them and asking for a new one because your current router is defective (which it is). If the router isn't still supported or under warranty though, there may still be a chance.

The next step is to look at alternative router firmwares such as Tomato, DD-WRT, and so on. This isn't my area of expertise, but generally these third-party (usually open-source) firmware builds are not only less buggy than the default firmware, but also provide more features. Unfortunately, only a limited selection of routers (and usually not the cheap ones) are supported.

If you're still out of luck after all that, just replace the router. A new one (of a different model, obviously) should work better. My home network has a mix of machines from Win7 to Win10, plus a couple Linux distros and FreeBSD, a smattering of mobile devices, and an Xbox 360, but has not had any such problems.

|improve this answer|||||
  • Thanks. The router is a ZyXEL P-660HW-T1 v3, provided by my ADSL provider. I checked myself at ZyXEL for firmware versions, though I cannot alter the router, but I wanted to know if there was a new version and contact them. There is not. We already updated the driver of the Win10 computer. – Vero Sep 10 '15 at 2:26
  • Just now, we had the Win10 computer on and connection reset constantly. We just happened to turn off a mobile phone which was also using WiFi, and instantly the connection stopped resetting itself. As if the Win10 computer finally got what it wanted. The phone is not the cause, router is ok when the phone is using WiFi. Maybe the router is not compatible with Win 10? – Vero Sep 10 '15 at 2:26
  • For a router to be "not compatible with Win10" is like saying a telephone isn't compatible with calling certain people. The router has a fairly simple job: shuttle bits around, in conformance with well-established standards for Ethernet and IP traffic. It should neither know nor care what OS is running on the source or destination of those bits, any more than a telephone should care if you speak English or Chinese. I use a DSL modem/router myself (though it's a Motorola) and an ancient router set as a switch, and neither have any problem with Win10 despite being years old. – CBHacking Sep 10 '15 at 7:28
  • I understand what you say. The thing is the issue is puzzling and it started happenning right after upgrading to Win 10, so it is something related to that upgrade, whatever it is. It seems to happen when the computer tries to get an IP address through DHCP. What could cause such a behavior? I read about someone with the same issue, in his case the computer had ethernet cable and wireless and tried to connect with both at same time. He disabled automatic wireless and was ok. Mine doesn't have an ethernet cable so that's not it. – Vero Sep 10 '15 at 11:20
  • You could try using Wireshark on each system to compare the DHCP requests from the 8.1 and 10 boxes. There probably is a difference between them, but it's probably something really stupid like a field being one character longer than the router's DHCPD was ever tested with and it having a buffer overflow. – CBHacking Sep 10 '15 at 18:20
-1

For those who come see this question, we could resolve the issue by changing to a newer router. It got solved immediately.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.