28

I am trying to set up a mobile hotspot in Windows 10 but the settings are disabled and the error message does not explain what the exact problem is.

Error in Windows10 settings dialog

The machine in question is a VM in VMWare Workstation and has a Wi-Fi and a cellular USB-stick attached. I had tried MyPublicWiFi before I discovered that Win10 had built-in settings for this, but now I have uninstalled MyPublicWiFi.

So, does anyone know what could cause the above mentioned error message?

Edit: I still don't know the reason for the error message, but it went away after I used a different Wi-Fi USB-Stick!

5
  • How is this machine connected to the internet now? Is is connected to Ethernet or WiFi?
    – CharlieRB
    Sep 10, 2015 at 11:35
  • The internet connection is provided through the cellular USB-stick (UMTS/LTE). I have removed the default Ethernet device from the VMs hardware settings.
    – frank koch
    Sep 10, 2015 at 13:26
  • I've tried to unplug and plug-in the cable a couple of times. Then the error vanished. -_-
    – Prabs
    Dec 18, 2016 at 21:00
  • 1
    In windows search box type Device Manager and open it. In Device Manager menu View>Show hidden devices click on that. Now you will find the Network adapters > Microsoft Wi-Fi Direct Virtual Adapter , So just disable and enable it. Its resolve my problem. Jan 18, 2019 at 6:37
  • Interestingly rebooting my pc solved the issue
    – Blue Print
    May 24, 2020 at 9:56

2 Answers 2

26

I had the same problem, I couldn't get that to work but there is a way to activate a hotspot, follow the steps below.

  1. Open CMD as Admin (WIN+X, "Command Prompt (Admin)"). Enter the commands as below.

  2. netsh wlan set hostednetwork mode=allow ssid=name key=pw

    • Substitute your preferred Hotspot Network Name for name and Password for pw
  3. netsh wlan start hostednetwork

  4. Go to "Settings>Network & Internet>Wi-Fi>Change adapter options" and look for a new "Local Area Connection #..." (It should show "Microsoft Hosted Network Virtual Adapter" as the Adapter). Right-click this and select "Properties", then select the "Sharing Tab. Check "Allow other network Users to connect through this computer's Internet connection"

Troubleshooting: If you find any errors such as "The group or resource is not in the correct state to perform the requested operation.": enter image description here

  • Type Win+X
  • Go to Device Manager
  • View / Check Show Hidden Devices
  • Search for a Network driver called "Microsoft Wi-Fi Direct Virtual Adapter"
  • Disable / Enable it enter image description here
  • Go back to the Mobile Hotpost settings
  • Now you might be able to enable it enter image description here
6
  • thanks for your reply - step 1 to 3 succeeded but step 4 is a bit unclear: I now have 3 connections in "Control Panel\Network and Internet\Network Connections": lte_stick, wifi (which has a red cross) and wifihosted. I have enabled connection sharing in the properties of lte_stick and in the box "Home network connection" I have selected wifihosted. When I try to connect to this hotspot with my Android-phone it prompts something like "retrieving IP address" and then shows an error.
    – frank koch
    Oct 6, 2015 at 13:42
  • A reboot helped me. Looks like an issue after suspending. Surface Pro 3 here. Jun 25, 2017 at 1:37
  • 1
    Gave me a problem where apparently it switched my ethernet from DHCP to the wrong static ip. The ethernet said "unidentified network" "no internet access". Switching it back to DHCP and stopping the hostednetwork fixed it, but obviously did not allow me to use the hotspot.
    – Erhannis
    Aug 23, 2017 at 16:24
  • @Erhannis I see the same problem. Any solution? Dec 4, 2017 at 10:05
  • @bradgonesurfing I don't think we ever got it working; sorry.
    – Erhannis
    Dec 7, 2017 at 16:05
0

I got this error after connecting/disconnecting another wifi adapter. I went to Device Manager and disabled then re-enabled the original adapter and the error went away

Not the answer you're looking for? Browse other questions tagged or ask your own question.