0

I recently upgraded my internet to a 200 Megabit connection, however, I seem to have some trouble with the NIC on my mainboard (Gigabyte Z77X-UD3H Rev 1.1).

For some reason Windows detects it as a 100 Megabit NIC and not a Gigabit one, which causes bad download speeds on my PC.

It is definitely not a problem with my router or the cable, as I am getting the full 200 MBit download speed when doing a speedtest on my (wired) Xbox and I've switched cables to make sure it wasn't a faulty wiring or anything.

I also made sure that the Speed/Duplex setting is set accordingly in the Windows settings, made sure the drivers are the lastest one available, etc.

Kinda out of options here... Does anyone have an idea on what I could try next? That's really a strange one :-/

enter image description hereenter image description here

  • Is your PC directly connected to the router, or do you have a switch in between? – FastEthernet Sep 10 '15 at 17:36
  • It's directly connected to the router and it's only like 3 meters away, so it can't be the distance. And as I said, I tried switch cables with the one my Xbox is connected to and while the Xbox had the proper speed again, the PC stayed at 100 Mbps. Also tried switching the router port the cable is connected to, nothing changed. I'm kinda sure it's a Windows problem – daZza Sep 10 '15 at 17:41
  • Whats the speed & duplex setting on your router? If one is at "Autonegotiation" and the other one is set at fixed speed and duplex things go wrong...Try to set this to autoneg on both machines or to fixed values on both machines. – duenni Sep 10 '15 at 18:15
  • Do you have a Xbox One? Otherwise it doesn’t have Gigabit anyway. Gigabit connections cannot be forced. They must be auto-negotiated. If either party decides it’s not going to work, it will fall back to slower speeds. Are your cables at least Cat5e? Are they near potential interference sources like AC motors, microwave ovens or wireless transmitters? – Daniel B Sep 10 '15 at 18:17
  • Yep, XBox One. The setting was on auto-negotatied before I changed it to 1 Gbps, so that's not the source of the problem. I'll change it back to auto-negotiated though. Cables are CAT-5e indeed, no interference sources nearby, well unless the wireless signal from the router can interfere with it. I doubt it though, as the XBox is getting the full speed (200 Mbps) – daZza Sep 10 '15 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.