0

Update: I mistakenly wrote Win RT instead of Embedded, corrected it.
Update: Added a bullet list to make it easier to see how the computers are configured.

I manage 13 computers running Win 8 embedded. A user is always logged on. The problem is that sometimes when a person wants to use the computer it is locked and he/she needs to type the password to login. The locking sometimes happen after about an hour, sometimes after a few days or even weeks. How is that possible with this configuration?

Configuration:

  • Never sleep or hibernate
  • Never turn off the monitor
  • No screen saver
  • Disabled the lock screen
  • Updates are installed outside office hours
  • When rebooted, user is logged in automatically
  • Users don't have access to start menu (only touch screen and a full screen app)
  • Users are not using the Win+l command
  • The computers are in an AD, but no GPO:s regarding locking exists (and the locking occurs different times on different computers)
  • Just checking: are the tablets configured to never sleep in either powered or battery mode? It's possible the power connector might be coming loose on one or two devices, causing them to spend some time running on battery. – CBHacking Sep 11 '15 at 10:04
  • Good idea, but they're desktops and always have power. They are also configured in BIOS to restart and auto-login after a power outage. – Carl Björknäs Sep 11 '15 at 10:32
  • Ah. I wasn't aware anybody was building desktops that run RT (Why...). In any case, this doesn't actually answer your question, but you may be able to make them automatically log in again using Task Scheduler. "Workstation is locked" is a valid trigger for a task, though I'm not sure how best to unlock (or prevent the lock) when it happens. – CBHacking Sep 11 '15 at 10:39
  • Also, anything in Event Viewer for the times when the devices lock? That should generate a log event, and you can possibly tell why from there. – CBHacking Sep 11 '15 at 10:40
  • My bad, it's Win embedded, not RT. So far I haven't seen anything special in the event log, and nothing that differs between the computers that have had the problem and the ones that haven't had it. – Carl Björknäs Sep 11 '15 at 10:54
0

None of the computers has auto-locked for a month now after my last changes. The changes I did was:

  • Disabled the scheduled task for SkyDrive (had generated an error in the event log)
  • Opt out of the "Customer Experience Improvement Program" and also disabled all related scheduled tasks
  • Switched the power profile from modified "Balanced" to "High performance" with the same modifications
  • Turned off auto-update and auto-update-check of TeamViewer
  • Turned off auto-update of Adobe AIR (seems like it has to be done for every user)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.