10

Yes, I did do sudo update-grub.

Changing the /etc/default/grub GRUB_TIMEOUT variable seems to work once, but then after that first time every time I reboot the timeout is 30 seconds and my time I set is ignored.

I am running Lubuntu and Windows 7. GRUB2 came with Lubuntu 14.04.

1 Answer 1

14

This could be an issue connected to GRUB_RECORDFAIL_TIMEOUT. According to the official Ubuntu documentation — which is still relevant to Lubuntu — it says:

If the last boot failed or after a boot into Recovery Mode the menu will be displayed until the user makes a selection.

To change this behaviour, edit /etc/default/grub and add the variable GRUB_RECORDFAIL_TIMEOUT. Set the value similar to setting for GRUB_TIMEOUT.

  1. For -1, there will be no countdown and thus the menu will display.
  2. For 0, menu will not display even for a failed startup.
  3. For >=1, menu will display for the specified number of seconds.

Run update-grub after the change have been made.

It could be that your setup is somehow just powering down and/or rebooting Lubuntu in a way that makes it feel that the last boot failed — or the system crashed — thus it’s going to look for the GRUB_RECORDFAIL_TIMEOUT value and use it’s default value if it’s not set elsewhere.

Regardless, here is how I tweak that GRUB_RECORDFAIL_TIMEOUT value.

First, open up /etc/default/grub using nano—or you can use whatever text editor you like—like this:

sudo nano /etc/default/grub

Then I set GRUB_TIMEOUT and then GRUB_RECORDFAIL_TIMEOUT like this:

GRUB_TIMEOUT=0
GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT

Note that I am setting GRUB_RECORDFAIL_TIMEOUT with a variable reference to $GRUB_TIMEOUT instead of setting a new number; feel free to change that to a real number if you need different timeout values.

Then I update GRUB and all should be good:

sudo update-grub2
3
  • seems to work. "sudo update-grub" seems to work too.
    – Leo Ervin
    Sep 11, 2015 at 19:17
  • 1
    In my generated /boot/grub/grub.cfg with stock Ubuntu 20.04, I see that for some reason all linux boot lines include the "recordfail" command, so they all seem to trigger this behavior. I don't know why. But this answer does fix it. Thanks. Feb 16, 2021 at 13:17
  • 2
    Does not work on latest 20.04 version of Ubuntu.
    – Dave
    Mar 27, 2022 at 18:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .