26

I've checked and my BIOS clock stays correct so it can't be the CMOS battery.

Also when I boot Windows 10 and the clock is an hour behind if I got and sync the clock with the time server it shows correctly.

So I'm not sure what could be causing the issue.

  • How quickly does the time drift or on every reboot? Time zone? Similar question: superuser.com/questions/221045/… – StackAbstraction Sep 11 '15 at 18:31
  • 1
    I think it's after reboot possibly after coming out of my Hackintosh partition. – Joshua Barnett Sep 11 '15 at 18:43
  • 2
    are Daylight savings time settings applied? Do both OSes believe they are in teh same time zone with the same Daylight savings settings? – Frank Thomas Sep 11 '15 at 20:06
  • Yes, and if it wasn't it would be an hour in front not an hour behind. – Joshua Barnett Sep 12 '15 at 18:30
  • Did you ever figure this out? I'm having the same problem on mac after upgrading to win 10. – Dax Fohl Mar 22 '16 at 14:28
35

Had this issue on my laptop and regular PC (both dual boot Windows 10 and Xubuntu) - the time was always 1 hour behind.

Before I give my solution, just to be clear;

  • Yes, BIOS showed the correct time
  • No, the BIOS battery was not empty
  • Yes, tried both with Daylight savings on and off
  • Yes, my time zone was set correctly
  • Yes, I did try different time zones as well
  • No, I did not mess up my region settings
  • Yes, I even changed time manually - but it would switch back nevertheless

What worked for me, was the following; change the "Internet time" settings to time.nist.gov.

  1. Go to Control Panel
  2. Go to Clock, language and region
  3. Select "Set the time and date"
  4. In the pop-up, go to tab "Internet time"
  5. Select "Change settings"
  6. Select the server time.nist.gov.

Time is now shown correctly again, even after restart.

If you are still having issues with time after these steps verify the Windows Time Service is running (w32Time)

  1. Open the Start menu and type "Services"
  2. From The list of options available select "Services"
  3. Click on any service in the list and then type "win" to be taken to the services with a name beginning "Windows"
  4. Find the "Windows Time" service and right click on it and open properties.
  5. Ensure the "Startup Type" is set to "Automatic" and then make sure you "Start" the service.

This should ensure that if you are using NTP (Internet Time) then you should be able to sync your clock on startup.

  • This fixed the problem for me as well, thanks – Floran Gmehlin Feb 26 '17 at 16:31
  • 3
    The Windows Time service not being set to Automatic was my problem, so thanks for that! – snark Sep 28 '17 at 18:42
  • Thanks for the super detailed answer, enjoy your reputation. – Joshua Barnett Jan 18 '18 at 15:13
  • Can't validate but i have a feeling this resets after windows has a big update like the one recently. – Joel Harkes Feb 1 '18 at 12:22
  • 1
    For me it was the service not running automatically. Thanks! – Aleksandar Savkov Jul 7 '19 at 16:54
5

Think I just figured this out on Windows 10.

Go to:

  1. Control Panel
  2. Click 'Clock, Language & Region'
  3. Click 'Change the time zone'
  4. Click 'Change time zone...' button
  5. Check 'Automatically adjust clock for Daylight Saving Time'

This immediately fixed the problem for me. Note that I'd already right-clicked the clock, selected 'Adjust date/time' and on that screen 'Adjust for daylight saving time automatically' was already on. It was only when I also turned it on for the 2nd time in Control Panel that my clock stopped being an hour behind after a reboot.

4

I have a dual boot Win 10 and ubuntu box. Originally I used Task Scheduler in Windows to force the action w32tm /resync /nowait to be run when any user logged on. This worked but it's pretty clunky.

Then I discovered via this answer that Windows and Linux make different assumptions about the hardware clock. By default Windows assumes it's set to local time whereas Linux assumes it's set to UTC. So, depending on your preference, you can either tell Windows to assume the hardware clock is using UTC, as in @juniorRubyist's answer; or tell Linux to assume the hardware clock is set to local time, as at https://superuser.com/a/1336320/576397 or https://superuser.com/a/198196/576397.

  • This seems like the more proper answer of all, thanks :) do you need to restart pc for this to take effect? – Joel Harkes Jan 29 '19 at 9:40
  • Possibly not but I'm sorry - I don't remember! Also, whether or not you need to reboot might depend on which OS you decide to alter. – snark Feb 4 '19 at 18:24
  • I experienced: it doesn't work directly. day later after reboot (back in windows) clock was 1 hour ahead. after a few hours it fixed it self. probably fixed now, have to try to boot in linux and back to windows to be sure. Thanks so much for this answer :) – Joel Harkes Feb 5 '19 at 8:22
0

All you need to do is right click the time/date in the bottom right, click "Adjust date/time", then turn on "Ajust for daylight saving time automatically".

My clock has been back an hour since I got this laptop a few days ago, all I had to do was follow these steps. I hope this works for anyone else experiencing the problem.

0

This works for me. Type Date & Time Settings in the search box and click on it, then turn on set time automatically and also turn on set time zone automatically. This will automatically select your time zone and adjust the time.

0

My problem seemed to be Windows failing to update time from the time server. The following makes Windows update from it's time server without changing it:

  • Open Control Panel
  • Go to Clock, Language and Region
  • Go to Date and Time
  • Click Set the time and date
  • Click tab Internet Time
  • Click Change settings...
  • Leave the time server but click Update now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.