4

I’m on a Lenovo ThinkPad T430 which had Debian Wheezy running solid/stable. No crashes, ever. Upgraded to Debian Jessie recently and been having crashes; it seems like Gnome crashes.

By crash, it just goes into that Gnome “System error has occurred page. Log out,” then it either restarts or I go back to my programs, and after 3-4 minutes it logs me out.

How can I get to the bottom of this or how can I at least confirm if this is either a system error, or bumblebee, or an xorg error? Here's the timeline of what I did:


  1. Updated /etc/apt/sources.list from wheezy to jessie
  2. Followed instructions and did a dist-upgrade
  3. GUI mode didn't work entirely - installed bumblebee which solved my initial issue of graphics/gnome entirely not working entirely ( non GUI mode )
  4. Used Gnome3 in regular mode and using it in fallback/classic mode but still get sporadic crashes

System Info:

  • Hardware: Lenovo ThinkPad T430
  • Gnome: 3.1.4.1
  • Processor: Debian GNU/Linux 8 (jessie) 32-bit
  • Graphics: (if this is accurate) Intel® Ivybridge Mobile x86/MMX/SSE2

Logs:

  • Xorg.0.log: http://dpaste.com/2WJNZJV
  • lspci reveals I actually have 2 VGA options, but how do I know which one is being used now?

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [NVS 5400M] (rev ff)

UPDATE #1

Just crashed at 13:51-13:52 and in /var/log I see:

-rw-r----- 1 root               18K Sep 14 13:51 debug
-rw-r--r-- 1 root               31K Sep 14 13:51 Xorg.0.log
-rw-r----- 1 root               95K Sep 14 13:51 kern.log
-rw-rw-r-- 1 root              160K Sep 14 13:52 wtmp
-rw-r----- 1 root              147K Sep 14 13:52 daemon.log
-rw-r----- 1 root              1.4M Sep 14 13:54 user.log
-rw-r----- 1 root              467K Sep 14 13:54 syslog
-rw-r----- 1 root              1.5M Sep 14 13:54 messages
-rw-r----- 1 root               27K Sep 14 13:54 auth.log

I checked each of those and the only thing that looked suspicious was:

Sep 14 13:51:36 oskol kernel: [40336.856002] VirtualBox[21056]: segfault at c ip b57d917b sp bf99a510 error 4 in VirtualBox.so[b5680000+6bf000]

Would that cause a crash or is that more of a warning?

UPDATE #2

I tried updating to the nvidia drivers as suggested and generating an xorg.conf file, but this I believe conflicts with bumblebee possibly and X can no longer start saying 'nvidia module not found'. I uninstalled those and renamed xorg.conf so there's none atm. I believe my card is an Nvidia Optimus card which needs bumblebee.

UPDATE #3

FileZilla randomly crashed and it logged me back out. Is there a way I can debug what sort of error this was?

UPDATE #4

I'm using 2 monitors today and one of them got the "Oh no! Something is wrong. The other monitor is fine.

UPDATE #5 -

Going on a couple months now and still haven't resolved this. Very close to backing up my entire HD and installing Debian afresh. More info:

  1. Settings -> Displays gives me "Could not get screen information"

  2. Xorg.8.log contains this:

[ 48783.817] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ 48783.817] (EE) NVIDIA(0):     system's kernel log for additional error messages and
[ 48783.817] (EE) NVIDIA(0):     consult the NVIDIA README for details.
[ 48783.817] (EE) NVIDIA(0):  *** Aborting ***
[ 48783.817] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 48783.817] (II) UnloadModule: "nvidia"
[ 48783.817] (II) UnloadSubModule: "wfb"
[ 48783.817] (II) UnloadSubModule: "fb"
[ 48783.817] (EE) Screen(s) found, but none have a usable configuration.

Full Xorg.8.log

  1. Tried jkwong888's solution of prepending a Screen Section to the top of bumblebee's xorg.conf.nvidia to no avail.

  2. optirun -vv glxgears gives me this, which has some "failed to set DRM interface version"

optirun -vv glxgears
[  674.297893] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  674.298701] [DEBUG]optirun version 3.2.1 starting...
[  674.298749] [DEBUG]Active configuration:
[  674.298780] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  674.298796] [DEBUG] X display: :8
[  674.298810] [DEBUG] LD_LIBRARY_PATH: 
[  674.298824] [DEBUG] Socket path: /var/run/bumblebee.socket
[  674.298839] [DEBUG] Accel/display bridge: auto
[  674.298854] [DEBUG] VGL Compression: proxy
[  674.298869] [DEBUG] VGLrun extra options: 
[  674.298883] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[  674.298967] [DEBUG]Using auto-detected bridge primus
[  674.418536] [INFO]Response: No - error: [XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied
[  674.418552] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied 
[  674.418557] [DEBUG]Socket closed.
[  674.418570] [ERROR]Aborting because fallback start is disabled.
[  674.418575] [DEBUG]Killing all remaining processes.
  • First, look at the system logs. Do they contain anything relevant-looking from around the times when the crashes occur? – a CVn Sep 11 '15 at 20:11
  • Can you reference the system log files? Since I think there are different types of logs pertaining to diff parts of the system. – meder omuraliev Sep 11 '15 at 20:33
  • 1
    One thing is always dmesg. This would usually mean "low-level" problems, ie. programs crashing with SIGSEG or similar faults. As we aretalking about GUI-faults, a look into Xorg.log.X might be useful (/var/log/Xorg.log.0). /var/log/messages and ~/.xsession-errors are also locations of logs. In case you are using systemd (I assume not as you upgraded) you might also have a look here: ask.fedoraproject.org/en/question/45921/… – larkey Sep 14 '15 at 5:35
  • 1
    The drivers could be the problem too ofcourse, although I wonder what you did. Usually intel GPU drivers are good enough to not need intervention. Just type lspci and check for "3D"/" Video"/"Display" or similar - maybe you also have a dedicated GPU? – larkey Sep 14 '15 at 5:37
  • 2
    If you suspect that X11 is the cause of the crash, you may just disable it, systemctl disable lightdm or whichever manager (gdm, kdm,..) you use, reboot and log in via the CLI, see whether the computer crashes at all. You may also try to reconfigure the X server, by means of dpkg-reconfigure xserver-xorg and so on. – MariusMatutiae Sep 15 '15 at 7:46
4
+175

This seems to be a driver issue.

First, you should reinstall the video drivers.

For Intel:

sudo apt-get install xserver-xorg-video-intel

For NVIDA:

Use the legacy driver (Version 304.125) as it supports your NVIDIA® NVS 5400M graphics card as listed here and described below.

From resource:

1) Add "contrib" and "non-free" components to /etc/apt/sources.list, for example:

Debian 8 "Jessie" deb http://http.debian.net/debian/ jessie main contrib non-free

2) Update the list of available packages. Install the appropriate linux-headers and kernel module packages:

aptitude update aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-legacy-304xx-kernel-dkms

This will also install the recommended nvidia-legacy-304xx-driver package. DKMS will build the nvidia module for your system.

3) Create an Xorg server configuration file.

4) Restart your system to enable the nouveau blacklist.

If that still does not work, then try a clean install of Debian 8 and then adding each driver/feature as needed (doing some integration testing with each).

  • How did you determine it's a video/graphical issue? I believe I may have tried this before but I'm gonna try it again now and let you know. Still getting crashes after whatever I tried 2 months ago. – meder omuraliev Nov 25 '15 at 23:43
  • Ok - I followed these instructions but this resulted in the nvidia module not being able to load. I believe because I have bumblebee-nvidia installed, which is for Nvidia Optimus graphics cards. I had to rename the Xorg.conf so it wouldn't get loaded. So should I use bumblebee or this if my GFX is Optimus enabled? – meder omuraliev Nov 26 '15 at 0:09
  • I'm not familiar with your situation entirely but the issue is directly related to the software (firmware) that interacts with your graphics card. I would simply contact the manufacturer of the card and as for help. The worst (and most probable) reason is that they have stopped supporting your hardware... – Matthew Peters Nov 27 '15 at 4:41
0

that VirtualBox segfault could very well be the culprit. Try

$ VBoxManage list extpacks

So go https://www.virtualbox.org/wiki/Download_Old_Builds_4_3, and download the extpack -All Platforms- for v. 4.3.18 (or the version is now installed).

Then you start vbox. Go to File > Preferences and then the Extensions tab. Select the little arrow on the right to Add File. Browse to your downloaded .extpack, and the rest is automatic. It pops up a window asking whether you want to upgrade (hit the little upgrade button).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.