14

Booting an instance in VirtualBox fails due to:

RTR3InitEx failed with rc=-1912 (rc=-1912)

where: supR3HardenedMainInitRuntime
what:  4
VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.

Booting an instance works in 5.0.2.102096 while it fails in 5.0.4.102546


Attempts to solve the issue

According to this Q&A and this Q&A the issue can be solved by reinstalling 5.0.4.102546

Current outcome

After reinstalling the issue persists

Question

How to solve this issue?

  • I have the same problem after upgrading from 5.0.0 to 5.0.8 on Windos 10. – Ben Collins Nov 6 '15 at 15:49
  • FYI, I had this error on Fedora 23. I had both i686 and x86_64 installed. I had to uninstall the i686 version which I had manually installed from a downloaded RPM. – HeatfanJohn Feb 22 '16 at 23:38
  • Hit this with 5.0.16, a re-install fixed it – KCD Mar 10 '16 at 2:25
3

On Windows, I finally succeeded to resolve this issue.

  1. Uninstall VirtualBox using the control panel "Program and functionalities" tool. DO NOT RESTART YET
  2. Manually check for the following folders and remove them if they are still there:
    • C:\Program Files\Oracle\VirtualBox
    • C:\Program Files (x86)\Oracle\VirtualBox

NOTE: the folders can be in a different place depending where you installed Oracle VirtualBox (make sure to check the correct folder in case you changed the installation directory).

  1. Go to %userprofile% directory (eg: C:\users\me) and delete the following folders (don't forget to backup those files if you want to try re-importing your VMs later):

    • .VirtualBox
    • VirtualBox VMs
  2. Go to regedit (WIN+R and type regedit) and click on Computer at the very top.

    • Then click on "Edit > Search" or hit CTRL+F. Type virtualbox and tick all checkboxes.
    • Find the key Oracle > VirtualBox. It should be in Computer\HKEY_CURRENT_USER\SOFTWARE\Oracle\VirtualBox. Remove VirtualBox key.
  3. IMPORTANT: RESTART NOW. Restart your computer !

  4. Install VirtualBox and Enjoy !

| improve this answer | |
  • In the 2nd step, do you refer to ProgramData with the first path, or to Program Files? (VBox doesn't seem to have anything in ProgramData so it must be the latter, right?) – zagrimsan Aug 11 '16 at 8:39
  • Yes, sorry. I edited the post to correct it. – Kursion Aug 13 '16 at 9:40
  • 1
    Good, that clarified thigns up. There are things in your solution that might surprise some users, like that deleting VirtualBox VMs will actually make them lose their virtual machines, so it might be better to first rename that folder (did you first try without cleaning up VirtualBox VMs at all?) so that later on one could try to get the VMs back by importing them in VirtualBox. – zagrimsan Aug 15 '16 at 3:26
  • I've added a note about backuping files before deleting the VirtualBox VMs and .VirtualBox folders. Actually, I tried a lot of things since I really need to have VirtualBox on my computer. After testing few solutions, this one was the most relevant. I guess that deleting the keys in the register should be enough but I didn't had the occasion to confirm that. Thus I posted the entire manœuvre that resolved my issue. – Kursion Aug 16 '16 at 7:37
2

Linux was not mentioned in the question, but my question was verbatim in VirtualBox 5.2 issue is happening for me in Ubuntu 16.04. Similarly, uninstall reinstall with the correct files resulted in the same error message. The problem was similar to the Windows issue, but in my case dkms was holding some older modules that were in conflict with the latest Virtual Box version.

The solution for me (change for your versions):

sudo apt-get purge virtualbox-5.2
sudo dpkg -P virtualbox-5.2
sudo apt-get autoremove 

I included the apt-get purge just in case you installed from apt-get while troubleshooting another problem.

At the autoremove command, you should see dkms updates removing several older virtualbox version modules. Aha, a reference to the source of our problem, wrong module version per the virtualbox error...:

vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.4.0-112-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.

------------------------------
Deleting module version: 5.0.40
completely from the DKMS tree.
------------------------------

Reboot for good measure

sudo reboot now

Then, download and install the matching versions of virtualbox and extensions (update for your current version): https://www.virtualbox.org/wiki/Linux_Downloads

sudo dpkg -i ~/Downloads/virtualbox-5.2_5.2.6-120293~Ubuntu~xenial_amd64.deb
sudo VBoxManage extpack install ~/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.2.6-120293.vbox-extpack

If the first install gives you a libsdll error, try:

sudo apt-get -f install

Hopefully then you should have a working VirtualBox, or progressed to dealing with new errors (VT-X crashes, etc...).

(Please don't flame for being a zombie thread, I got here from a search and the same symptoms. Thought others may have use for this information in the future as well.)

| improve this answer | |
2

To remove virtualbox, run:

sudo apt autoremove --purge virtualbox*

Now make sure there is no other version installed on your system by:

dpkg -l virtualbox* | grep ^i

You shouldn't get any output.

Then remove all related PPAs from your sources.list and sources.list.ddirectory. ex:

mkdir ~/apt-tmp
sudo mv /etc/apt/sources.list.d/* ~/apt-tmp

Make sure there is nothing except official repositories sources in

/etc/sources.list.

And update your sources:

sudo apt update

Now we can search to see which versions are available to install:

apt-cache madison virtualbox | grep -iv sources

Which produces an output like this:

virtualbox | 5.1.38-dfsg-0ubuntu1.16.04.1 | http://archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages

virtualbox | 5.0.18-dfsg-2build1 | http://archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages

Then install the lastest version mentioned above:

sudo apt install virtualbox=5.1.38-dfsg-0ubuntu1.16.04.1

Also sudo apt install virtualbox, would be fine, but I would go with the former command to make sure my desired version is going to be installed.

And after all, check that the correct version is installed.

From command line:

dpkg -l virtualbox* | grep ^i

which will output:

ii  virtualbox                     5.1.38-dfsg-0ubuntu1.16.04.1 amd64        x86 
virtualization solution - base binaries
ii  virtualbox-dkms                5.1.38-dfsg-0ubuntu1.16.04.1 all          x86 
virtualization solution - kernel module sources for dkms
ii  virtualbox-qt                  5.1.38-dfsg-0ubuntu1.16.04.1 amd64        x86 
virtualization solution - Qt based user interface

Then also you can run:

sudo apt upgrade

Just in case.

| improve this answer | |
0

These steps (taken from the above Q&A link) solved the same problem on my Win 10 (VBox upgrade 5.0.0 -> 5.0.10). It seems that point 5 may be important.

These are the steps I used to fix this issue on my system - Window 10 Home build 10240:

  1. Uninstall VirtualBox (through "Programs and Features").
  2. Make sure "VirtualBox NDIS6 Bridged Networking Driver" is uninstalled from network devices: Steps:
    • GOTO: Control Panel -> Network and Internet -> Network and Sharing
      Center -> Change adapter settings
    • Right-click your network device (mine was Dell Wireless 1703) and select "Properties".
    • Select the "VirtualBox NDIS6 Bridged Networking Driver" and click "Uninstall".
  3. (Optional) Restart your system.
  4. Install VirtualBox
  5. When prompted, make sure "Bridged Networking Driver" is set to NOT INSTALL!
  6. Done. Enjoy VirtualBox.
| improve this answer | |
0

This error also occurs when the version of an installed extension pack does not match the virtual box version. This can happen after an update of virtual box or if you are using the extension pack with a portable virtual box and move to a different pc (which obviously defeats the purpose of the portable virtual box). To fix that, you have to install or update the extension pack that suits your current virtual box version. Afterwards you need to restart the PC (restarting virtual box might also suffice but I didn't test that).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.