4

I am having a bad time trying to run Chrome on my CentOS 7.1 server. I know, it does not have a screen, it's a server. But I installed GNOME anyway and using VNC I can see the screen on a remote computer.

If I execute export DISPLAY=:0;firefox & I can see the firefox running just fine!

The problem is with Chrome. I installed it on my CentOS 7.1 and when I run it as "root" (I know I shouldn't, but in this case I can only run it as root cause no other user is allowed in this server) I get error message that is WELL SPREADED on the Internet and nobody still found a good solution.

I try to run chrome with this:

google-chrome &

I get this error:

[root@ip-172-31-49-160 /]# google-chrome &
[4] 11889
[root@ip-172-31-49-160 /]# [1:1:0912/031926:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
[1:1:0912/031926:ERROR:nacl_fork_delegate_linux.cc(314)] Bad NaCl helper startup ack (0 bytes)

Unfortunatelly Chrome does not open. What am I doing wrong?

**

**

4
  • related question: askubuntu.com/a/625691
    – nKn
    Sep 12 '15 at 16:44
  • No, in that question they say it was installed the i386 version but my version is x86_64. Many people on internet have this same error "Bad NaCl helper startup ack" for years, that's amazing nobody still came up with a solution
    – Mariana
    Sep 12 '15 at 19:53
  • is this topic already dead? Should I request to delete it?
    – Mariana
    Sep 14 '15 at 17:10
  • Try to open google chrome as regular user. Do not try to open it as root user. You will not get this error if you log into regular user account. Nov 25 '15 at 10:45
2

The first error message you're getting should be solvable by installing libexif

apt-get install libexif12

Concerning the second (and most relevant) message, Chrome is not designed to run as root. Running your browser as root is indeed a bad idea from security point of view, so you should do as @testdemoTestlast says and run it using regular user account. If for some reasons you need to run it as root, try

google-chrome --no-sandbox --user-data-dir
0

Try:

sudo yum install -y libexif

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.