Three weeks ago I used Rufus 2.2 to install Windows 10 on my machine, and it has write-protected my flash drive. I’ve tried diskpart:

att disk clear readonly 
create partition primary
format fs=fat32 quick

And it kinda worked, it removed the image off the USB, but now it’s showing:

Current Read-only State : Yes
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

And I can’t format it or write on it.

The drive is a a Kingston DataTraveler G4 32GB model, without physical switches. How would I restore it back to normal (rw) state?

  1. Use the + R (Windows logo key+R) keyboard shortcut to open the Run command.
  2. Type regedit, and click OK to open the registry.
  3. Browse the following path:

  4. Right-click the Control (folder) key, select New, and click on Key.

  5. Name the new key StorageDevicePolicies and press Enter.

    enter image description here

  6. Select the newly created key, and right-click on the right side, select New, and click on DWORD (32-bit) Value.

    enter image description here

  7. Name the new DWORD WriteProtect and press Enter.

  8. Double-click the newly created DWORD and change its value from 0 to 1.

  9. Click OK.

    enter image description here

10.Close the Registry to complete the task.

To revert the changes follow steps 1-10 above, but on step 8 change the DWORD value from 1 to 0.

Source: How to enable write protection for USB devices on Windows 10

  • 1
    The key is named "WriteProtect", not "write Protection". – Ray Jan 17 '17 at 19:15
  • in windows10 i'm unable to find this reg key :( – Mosè Bottacini Jan 28 '18 at 9:55
  • 1
    @MosèBottacini if you can't find the key you have to create it. Refer to step 4 in the answer above. – Jay Killeen Aug 21 '18 at 23:37
  • 1
    Though looking at this - you'd probably already have the dword at 1, and need to switch the value to 0 – Journeyman Geek Dec 31 '18 at 8:26

Go to this link and download “USB3.0 Repair tool” that is zip file.

Extract downloaded file and start restore.exe file and restore the disk

From Apacer site regarding the utility:

Unzip the file, double click to perform "Restore"

Some anti-virus (e.g. avast)software might block the "Restore", please shut it down or allow the tool be performed.

  1. Click “Restore”.
  2. Click “Restore” again.
  3. The screen shows “Restoring Device...”
  4. Please re-plug the flash drive when it shows “Restore Completed.”
  • 1
    It hasn't worked for me :( – joseantgv Jan 11 '17 at 15:26
  • 2
    The link is not working – Bhawin Jan 1 '18 at 17:04

I managed to solve with RMPrepUSB https://www.rmprepusb.com/ and I had the issue with an SD card I wanted to erase.

  • Can we get more information on how this was done? – NBN-Alex Jul 10 '17 at 18:05
  • sorry for the delay, I simply wiped the card removing the partitions that I could not delete with the native tools in windows. To do that use the button "prepare unit" that wipes it and creates a new partition – user1708042 Jul 17 '17 at 10:35

I managed to repair my Kingston 32GB USB key using Phison Format & Restore tool (I did not find it on any official site, so I recommend to scan the file for viruses before using it).

How to use it

Insert the USB key and remove any other USB device from computer

Launch the tool

format and restore tool

Click the Restore button and confirm deletion

  • If there's no official link from the developer or a trusted site, I personally don't believe software should be linked to or recommended... That box alone throws up red flags galore. – JW0914 Dec 23 '19 at 5:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.