2

I have a very odd problem that happened to me twice since I clean installed Kali Linux V2.0 a month ago. Both times I handled the problem by clean installing the OS again. I looked it up online for hours but couldn't find any solution for the problem or any issue similar to what I had.

What I experienced was a freezing at the login page.

This occurred after I shutdown the system with the power button. The shutdown procedure was stuck for some reason and eating my CPU (according to the fan speed and heat).

I reopened the laptop and booted into Linux, but this time all the data that was being displayed on the screen while booting was in a different font size. After that I got to the login page again, with a different resolution, the system froze, I couldn't move the mouse, use the keyboard etc.

Again ... CPU was working hard according to noise of the fan.

I also tried to get a shell command using the ctr+alt+f2 but no luck..

I haven't installed any custom driver or any program the can cause the problem. I'm using Sony Vaio z45gd laptop

Kernal : 4.0.0-kali1-686-pae
CPU: Intel® Core™2 Duo CPU P9700 @ 2.80GHz × 2

I have 2 hard drives. Linux is installed on Samsung SSD 840 EVO 250GB (EXT0CB6Q) I'm using Grub to choose what to boot, (the second boot OS is windows 7).

Graphics: Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
BIOS Information
Vendor: INSYDE
Version: R4043M3
Release Date: 08/24/2009
ROM Size: 1536 kB

Characteristics:
PCI is supported
PNP is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
EDD is supported
8042 keyboard services are supported (int 9h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
Smart battery is supported
BIOS boot specification is supported
Function key-initiated network boot is supported
Targeted content distribution is supported
BIOS Revision: 40.43
Firmware Revision: 40.43

Should i post any more info?

2
  • Next time this occurs, use some of these codes to investigate what is happening, en.wikipedia.org/wiki/Magic_SysRq_key May 29 '17 at 19:55
  • When you powered off the system with the power button, what was running on it? I doubt that your system might be running a system upgrade. And force shutting it down causes these kind of issues. I have experienced similar kind of issues with a Linux Mint system in the past.
    – rajudev
    Jun 1 '17 at 20:32
1
+50

i am just assuming you get graphical error, as i froze last time that i used nvidia graphic.

did you configure your graphic to be such nvidia, or others? in driver manager before this error?

but first thing, to go go the terminal while in the black screen try to use ctrl+alt+ f1-f6, just try all of them until you get into one of them, cause you onyly posted using ctrl+alt+f2 which it didnt work. So try again and see what happens.

secondly, try to remove your graphical diplay by using , for example sudo apt-get purge nvidia*. -> nvidia* means purging all of the nvidia components. then reinstall then using, for example sudo apt-get install nvidia-current-updates.

finally restart your PC.

point to be noted, sometimes when you are in the terminal, you are not automatically connected to the internet, using nmcli d wifi connect [name of your SSID] password [your password] wlan0 .

1
  • @Kaldy Imanie Thanks a lot for your replay , I hadn't done anything or install anything last time it happened, just used to serf to web You-tube and compile basic C programs ... I will try all of your steps next time it will happened, but i why should i install Nvidia graphics components if i don't have Nvidia graphic card? Sep 12 '15 at 23:33
1

You can try following, This worked for me: 1. When at login screen, Press Alt+Ctr+F3. You will land on terminal window. 2. Enter your credentials. 3. Since your apt-get update && apt-get upgrade was inturrupted, please try following command: "dpkg --configure -a". This will resume your installation. 4. Let it complete, reboot the system. 5. You will be in upgraded Kali linux.

0

So here is what I've done to fix the problem:

  • Booted Kali in recovery mode
  • Logged into the root account by typing the password when prompted
  • nano /etc/gdm3/daemon.conf
  • Uncommented the automatic loginenable = true and the automatic login = root
  • Ctrl+O (saved) and Ctrl+X (exit)
  • Ctrl+D (exit terminal)

I let the recovery finish and I got the desktop back.

Note: You might fix the problem just by entering recovery mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.