1

I've been having trouble connecting between wired devices on my LAN since I switched to a DD-WRT based router (Windows 8.1 cannot connect to one specific device on LAN). My wireless devices can communicate with my wired devices just fine.

I found an answer on a related question that may solve my problem, but I can't find the specific setting in DD-WRT that the answer refers to. Can anyone shed some light on what this setting is and where I can find it? I am running DD-WRT v24-sp2 (04/09/15) std.

It's possible your wireless router is not allowing communication between clients. It's common for wireless routers to deny communication between hosts that are connected to it via the WLAN interface. Some wireless routers have options in their setup program to allow/deny communication between clients.

migrated from serverfault.com Sep 13 '15 at 18:29

This question came from our site for system and network administrators.

  • I confirmed this is definitely an issue only between two wired connections. I accessed wired computer A from a laptop B while laptop B was connected wirelessly to the router. This worked fine. Then I disabled the wifi on laptop B and plugged laptop B directly into the router. I was able to surf the web from laptop B (so I know I had a good network connection) but I could no longer connect to computer A, as both devices were now directly wired into the router. – mwolfe02 Sep 13 '15 at 19:02
  • How exactly are you testing the connection between computers? – h0tw1r3 Sep 13 '15 at 23:28
  • Ping, tracert, and http. – mwolfe02 Sep 14 '15 at 2:08
1

I eventually found an existing question that matched the symptoms I was experiencing. The solution worked for me as well, but I wanted to expand on it a bit.

Here's the step-by-step to enable the Virtual LAN in DD-WRT so that devices hard-wired to the router can communicate with each other (I'd love to know why this is not enabled by default):

  1. Go to DD-WRT administration webpage (usually 192.168.1.1 on a home network)
  2. Click on Administration tab
  3. Click on Commands sub-tab
  4. In the "Commands" text area, type:

    swconfig list
    
  5. Click the button, Run Commands

    • You should see one of the following results (most likely):
      • Found: switch0 - eth0
      • Found: switch0 - eth1
  6. Enter the following in the "Commands" text area (*note: replace eth0 with eth1 if needed to match the results of the swconfig list command):

    swconfig dev eth0 set enable_vlan 1
    swconfig dev eth0 set apply
    
  7. Click the button Save Startup

  8. Click on the Administration tab at the top of the screen
  9. Scroll all the way to the bottom and click the red button Reboot Router
  10. Verify the problem has been fixed following a router reboot

What the above steps do is save a startup script that runs whenever the router is rebooted. Saving it as a startup script is not necessary, but the alternative is that you would have to remember to run the two commands to enable the virtual LAN anytime the router got rebooted.

You could also run the commands to enable and apply the VLAN setting using the [Run Commands] button if you wanted to get immediate feedback without rebooting the router. I left that out because I was trying to minimize the total number of steps needed to achieve the desired end state.

  • Lifesaver for me and LAN parties. Thanks! – addMitt Jul 4 '16 at 4:39
  • 1
    Using a build from 12/15/2017, you get: sh: eval: line 1: swconfig: not found – SvdSinner Dec 26 '17 at 21:08

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.