7

Update

I've mentioned this in the comment already, but it's worth repeating here to avoid any misunderstanding: this issue is gone after numerous Windows updates. This means that unfortunately I won't be able to test/accept proposed solutions. Hopefully your comments will help someone else, though, so thank you for writing them!

Original issue

I've upgraded to Windows 10 Pro and have a strange issue with Windows Search: whenever a search result is a Control Panel item (e.g. "Administrative Tools", "Mouse", "Sound" etc.; and I'm talking about the old style Control Panel, not the new better looking Settings window) I can't open them with a click/enter! This issue also applies to a few other setting items not directly visible in the Control Panel (e.g. Disk Management settings such as "Create and format hard disk partitions").

Other search results are functioning just fine: I can open apps, files, Control Panel itself, settings exclusive to the new Settings window, e.g. "Pen and Touch" (it's a guess re exclusive, since when a setting item is available in both old Control Panel and new Settings, I can't open it), etc.

I can use the settings themselves just fine, but I have to first open the Control Panel itself, which is rather annoying.

  • Just tested this again after numerous Windows updates and this issue is no longer there. Still have no clue as to why it was there to begin with. – Evgeny Apr 20 '16 at 15:23
  • I'm having a similar issue. The biggest change since I noticed the control panel items not working is I installed the Anniversary Update. At first I thought it was just the sound control, but after some further testing, it seems to be every (or at least most) old fashioned control. – MBraedley Sep 5 '16 at 3:14
  • @MBraedley Did you already try SFC /SCANNOW from an elevated command prompt? You might also try running cpl_file_assoc and then rebooting afterwards and then seeing if you still have the issue. As a last resort, you could try resetting Windows 10 – Pimp Juice IT Sep 5 '16 at 4:29
  • I tried that command, and it wouldn't run successfully (I was in an elevated command prompt). I'll try the file association thing in the morning. – MBraedley Sep 5 '16 at 4:33
  • @MBraedley Be sure to look into resetting Windows 10 as well if you need to and it's applicable. – Pimp Juice IT Sep 5 '16 at 4:35
0

There is a fair amount of evidence that adding or removing additional languages in windows 10 can break search capabilities, specifically including control panel items not showing up in searches.

Since you are using multiple languages, this seems to line up well with your issues. The theory is that different components of Windows search end up with different language settings which (it gets less clear here) breaks things.

The fixes offered up are fairly consistent:

  1. Remove all languages besides English.
  2. Rebuild the search indexes.

To remove installed languages run the following command in an elevated command prompt and follow the prompts:

 Lpksetup /u

Then rebuild the indexes:

From Indexing Options, Advanced Options, click Rebuild to begin reindexing. Then restart Windows.

Sources:

superuser
superuser
tenforums

  • Search isn't the problem, and I don't think it was for the original asker either. The problem is that I couldn't open most old style control panel dialogs. – MBraedley Sep 6 '16 at 21:57
  • Considering the common ground your situation/ issue has with the links I provided its probably worth it to at least try the language removal. Is it probably your issue? Probably not. But its more likely than anything else that's been tried thus far. – Argonauts Sep 6 '16 at 22:31
  • No, the search is a red herring. Ignore it. – MBraedley Sep 6 '16 at 22:38
  • 3 languages installed during anniversary upgrade; similar area of problems. Suit yourself. You should probably ask this as a new question as a 'fielded' solution to the opening question is so far wrong as not to merit trying. Its a bit confusing. The mods could likely move the bounty if you opened a new question ( I'm guessing). – Argonauts Sep 6 '16 at 22:52
  • There is a solution that seems to work for most users over here: superuser.com/questions/950102/… – Wouter Feb 23 '17 at 16:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.