All of the sudden today Windows 10 stopped resolving names. When I try to do nslookup I always get this message:

S:\Users\dzoni>nslookup google.com
Server:  UnKnown

*** UnKnown can't find google.com: No response from server

But what is strange is that only Chrome is working perfectly, it has no issues in resolving names and browsing works as expected. Everything else is unable to resolve. There is no IPv6 setup so that shouldn't cause issues. I have a local DNS server and all other PCs are working fine.

I've tried different DNS servers, disabled the Firewall, flushed the DNS cache, reset the NIC and still nothing.

  • Do you have multiple network adapters? Are you sure chrome can resolve anything else than google.com (it has that built-in)
    – Spokey
    Sep 14, 2015 at 13:15
  • Yes I have a wireless adapter as well but it's disabled. I tried using it and I have the same issues as on the Ethernet adapter. I am using Chrome to post here.
    – Dzoni
    Sep 14, 2015 at 13:37
  • Is the DNS Client Windows Service running?
    – CharlesH
    Sep 14, 2015 at 15:27
  • @CharlesH Yes the DNS Service is running, I tried restarting it but to no avail. I am starting to suspect that the PC is infected with something. It's acting very strange, unable to start specific administrative tools, this DNS issue. However Avast and Malwarebytes reported the PC is clean.
    – Dzoni
    Sep 14, 2015 at 16:17
  • It is very strange, have you tried running a SFC /Scannow from administrative command prompt?
    – CharlesH
    Sep 15, 2015 at 6:56

1 Answer 1


On @CharlesH's suggestion I performed a system scan and found out that the system was infected with some malware that messed up all the services. Only solution is to perform a clean install.

All I can say, people be very very careful what you install on your computers.

  • Glad I could help!
    – CharlesH
    Sep 15, 2015 at 10:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .