3

After upgrading to Windows 10 from Windows 7 I am unable to find the VisualSVN Server graphical management console.

Previously, in Windows 7 through my start menu I had a "VisualSVN Server Manager" application which I could run and would open the GUI. This application is missing from my start menu after upgrading to Windows 10.

Further after looking in C:\ProgramData\Microsoft\Windows\Start Menu\Programs there is folder called "VisualSVN" which empty. I'm guessing there is supposed to be an appropriate shortcut in that folder that somehow went missing after the upgrade to Windows 10.

I took a look in the installation directory and couldn't find any executable which looked appropriate.

I am able to run the "VisualSVNServer.exe" found in the binaries directory and the service does start and I am able to connect to my repositories and update/commit/etc... using an appropriate svn interface like TortoiseSVN.

So it appears that everything is still installed correctly and I've simply lost the graphical management interface. Can anyone point me in the right direction in order to get it back?

Update

It looks like the management console for VisualSVN is a Windows MMC snap-in. Knowing that I felt comfortable running the "VisualSVN Server.msc" right out of the bin folder in VisualSVN's install directory which does get the management console to pop up, but there's an error:VisualSVN Error "Provider is not capable of the attempted operation (0x80041024)

This similar topic does describe this same error: Visual SVN Server on Windows 10

However, in my case the network location of my repository (let's call it //SharedDrive/User/Repositories) has not changed and I never had it mapped to a drive letter in Windows. But here's where I think the problem lies: at one point in time I had a repository on a different network drive (which we'll call //OldSharedDrive/User/Repositories). OldSharedDrive failed and we migrated everything to SharedDrive. At the time I updated my repository location in VisualSVN to manage the new location on SharedDrive and everything was fine and working well back in Windows 7. Fast forward to post-Windows-10-upgrade and we encounter the issue as first described in this question. But now if I attempt to repair, uninstall, or modify VisualSVN using Windows Programs and Features all operations issue a warning that //OldSharedDrive/User/Repositories cannot be found and the installer is forced to terminate unsuccessfully.

I'm guessing there is some keychain file somewhere that I simply need to remove the OldSharedDrive location from and I should be able to repair my installation?

1
  • TY for the additional info. Updated the answer. – bahrep Sep 21 '15 at 17:49
1

This solution got my GUI working again:

  1. Open a command prompt with admin rights.

  2. Go to the correct directory. This is mine below for example:

    cd \Program Files (x86)\VisualSVN Server\WMI
    
  3. Run the following command:

    mofcomp VisualSVNServer.mof
    
1

Read the article KB100: Error code 0x80041024 after upgrading to Windows 10 for instructions on how to solve the problem.


Outdated answer:

  1. In Windows 10 search box type VisualSVN Server Manager. Don't you get a shortcut to VisualSVN Server Manager console as a result?

  2. If you don't, go to Control Panel | Programs and features and run Repair for VisualSVN Server.

Update

The error 0x80041024 has to be solved by repairing VisualSVN Server through Control Panel | Programs and features. However, since the repair fails due to stale repositories location, this repair issue should be resolved before you are able to repair the server.

Сontact support@visualsvn.com for additional investigation. Please attach VisualSVN Server installer / upgrade logs to the email. The logs should be located in %TEMP% directory and named like MSI*****.LOG, e.g. MSIf34d9.LOG. There should be multiple logs with such name, please attach all of them.

3
  • Yea, #1 is where I started; nothing there. As to #2, my first thought was to try the repair, and barring that try uninstall then re-install. Unfortunately there is a stale repository location that causes both the repair and uninstall routines to fail. Message reads "Could not access network location \\whatever\wherever\Repositories". Only options are to retry or cancel the process. Retrying is meaningless because the location is truly no longer present. – Automaton Sep 16 '15 at 14:08
  • I've updated the original question to include more detail regarding your item #2. – Automaton Sep 16 '15 at 14:46
  • My brain hurts. The value in RepositoriesRoot was the correct location, '//SharedDrive/User/Repositories', but I changed it anyways as you described in step 3 and tried running the repair again. I get the same error as before: Could not access network location '//OldSharedDrive/User/Repositories'. I'll followup with the bug report as you suggested. Thanks for the help @bahrep! – Automaton Sep 24 '15 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.