I’m trying to create a new file using VLC that is trimmed from the original. I do not wish to transcode. I'm using the command:

vlc -I dummy "L:\temp\input.mp4" --start-time 71 --stop-time 74 --sout-standard-access=file --sout-standard-dst="L:\test2.mp4"

I get no error messages pertaining to L: drive access, the file plays (in subset), but no new file is created. What am I missing? When using -vvv, I get no errors requiring further parameters, making me think I’m not missing a required param, but I can’t tell.

Note: I know I can use :sout to chain the parameters more elegantly, but for the sake of debugging and learning (the CLI documentation isn't new-user-friendly), I’m endeavoring to list each parameter as described on that page:

You may also use the following syntax :  
`% vlc input_stream --sout-module1-option1=... --sout-module1-option2=... --sout-module2-option1=... --sout-module2-option2=... ...`

Edit for clarity:

VLC is in my PATH.

Breaking down the command, I understand it to mean:

  • vlc Run VLC
  • -I dummy Display a dummy (CLI feedback) interface
  • "L:\temp\input.mp4" Input file is this
  • --start-time 71 Start at 71 seconds
  • --stop-time 74 Stop at 74 seconds
  • --sout-standard-access=file Output using Standard accessing a 'file'
  • --sout-standard-dst="L:\test2.mp4" Output using Standard destination is L:\test2.mp4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.