1

I have a problem with my laptop. It has Win 10(64bit) with Realtek High Definition Audio.

Whenever I plug my headphones into the headphone jack, I hear a constant high frequency beep on the right headphone. It's not loud but annoying. Even if I mute everything, disable microphone input, unplug all usb etc, I can still hear it. With cheap headphones, I can't hear the beep( mostly because the high frequency is only noticable with quality headphones).

I tried uninstalling the driver and reinstall it, but I keep hearing the beep.

But I've found a little solution: When I go to the volume mixer, and press on the system sound bar and the typical windows sound appear, and plug the headphones while the sound is still playing, then I don't hear the high frequency beep anymore as long as the system is not off. Even when I unplug and plug the headphones , there is no beep. But when I unplug the headphone, wait some seconds and then plug them again, the beep appears again.

I really want to fix this problem so I don't want to depend on that trick. What could be the cause of this beep?

1

Assuming you didn't have this problem before you had windows 10, and you upgraded from a lower windows, it is likely that your soundcard drivers are somehow causing this. If this is indeed the case, it requires a special method to reinstall the drivers.

  1. Go to your Control Panel, System, Device Manager.

  2. Find your soundcard driver.

  3. Right click and choose Uninstall.
  4. Make sure you check the button: Also remove drivers. If this option is not available, then you didn't select the right soundcard.

  5. Reboot your pc

  6. Install your soundcard again.

-2

I had the same problem. Turned out to be interference from my WiFi Router which was right next to my speaker that has the headphone jack, power button, volume control. I simply switched that speaker to the other side of my monitor, and the other speaker where it was, and the constant beeping was gone. I'm using a newer laptop that came with Windows 10. To first troubleshoot it, I un-plugged my WiFi router, and the beeping stopped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.