0

Following the steps to install xplico (a program):

sudo bash -c 'echo "deb http://repo.xplico.org/ $(lsb_release -s -c) main" >> /etc/apt/sources.list'
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 791C25CE
sudo apt-get update
sudo apt-get install xplico

When I'm at the step 3 (update) I get this error:

W: Failed to fetch http://repo.xplico.org/dists/rafaela/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://repo.xplico.org/dists/rafaela/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

This is a problem because I need to update it successfully before being able to install it. I tried it on my kali machine which worked perfectly. Now, I tried to install the xplico_1.1.0_amd64.deb (22.1 MB) but when I doubleclick it, it says I dont have the right version of python (3.3) BUT I have the version 2.7 and the version 3.4 .... Thanks for your help guys!

  • 404 error is an answer provided by the server, that mean "not found" that folder or files do not exist – Francisco Tapia Sep 14 '15 at 21:05
  • Francisco Tapia I know that but my question would be, what are the alternative if there is one? – Bob Ebert Sep 14 '15 at 21:09
0

You were trying to install software from a repository for Ubuntu, but you are using Linux Mint and so the first command created a false entry in /etc/apt/sources.list. Instead of "rafaela" (the Mint code name) the line for your repository should include the code name of the Ubuntu version your Mint release is based on (that is apparently Ubuntu 14.04, "trusty").

Replace in /etc/apt/sources.list rafaela with trusty and try again.

It will probably allow you to download this package, which will probably work for you.

| improve this answer | |
  • doesnt work: still a 404 page not found, I'll try again with my kali machine to see what is the comand used – Bob Ebert Sep 14 '15 at 21:37
  • Have you tried installing the package (the one I have linked to in my answer) directly? – Thomas Weinbrenner Sep 14 '15 at 21:39
  • just by double clicking it? – Bob Ebert Sep 14 '15 at 21:40
  • Downloading it and installing via dpkg -i – Thomas Weinbrenner Sep 14 '15 at 21:43
  • YAY!! works like a charm (for the moment) before accepting the answer, can you please answer my 2 questions?: 1) in the source.list, there is a copy of the same line 6 times with the rusty, do I delete some and do I place it back to rafaela? 2) Can you tell me in which case I can use this answer / which package to look for to install ? thank you very much :D – Bob Ebert Sep 14 '15 at 21:46
0

As Thomas pointed out, the link in your sources.list is incorrect. If you check http://repo.xplico.org/dists/ you'll see the supported distros:

  Name                    Last modified      Size  Description
  Parent Directory                             -   
  natty/                  28-Sep-2013 13:45    -   
  oneiric/                28-Sep-2013 13:45    -   
  precise/                28-Sep-2013 13:45    -   
  quantal/                28-Sep-2013 13:45    -   
  raring/                 03-Nov-2013 01:33    -   
  saucy/                  26-Dec-2013 07:47    -   
  trusty/                 25-Apr-2014 06:51    -   

So your link in sources.list should include one of the above distros to be able to apt-get update.

Note: please make sure your distro is compatible with one of the above mentioned before running apt-get update and apt-get install!

| improve this answer | |
  • actually it is not, but do you know if kali linux is compatible for any of them? – Bob Ebert Sep 14 '15 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.