0

I’ve installed a Linux distro on an external USB hard disk drive through a live session on a virtual machine with my USB hard disk connected. I partitioned the external USB hard disk to three primary partitions, a 900GB NTFS containing personal files, 25GB Ext4 contains Linux root directory and a 2GB swap partition for Linux installation.

However my laptop refuses to boot from external hard disk, even though the external hard disk is the first boot priority in BIOS config, it just skips through my hard disk and boots from other devices instead.

Through the live linux session, I examined my external hard disk and my created partitions are there along with files from Linux installation.

  • you have to install boot manager (Grub) on the external disk: boot from live disk and then mount /dev/sdX /mnt/ mount -t proc none /mnt/proc mount -o bind /dev /mnt/dev chroot /mnt/ /bin/bash /usr/sbin/grub-install --recheck --no-floppy /dev/sdX reboot – jet Sep 14 '15 at 23:06
  • You say this is on a virtual machine but you don’t mention which virtualization software you’re using. Is it VirtualBox? VMware Fusion? Something else? – JakeGould Sep 15 '15 at 0:22
  • It's virtual box. I already tried installing grub but I can not mount sdX because it's busy I can only mount a partition sdX2 then install grub on sdX, but even grub gave no errors during installation process, I couldn't boot from it. – rosesarered Sep 15 '15 at 19:41
0

You have to install boot manager (Grub) on the external disk:

Boot from live disk and then:

mount /dev/sdX /mnt/
mount -t proc none /mnt/proc
mount -o bind /dev /mnt/dev
chroot /mnt/ /bin/bash
/usr/sbin/grub-install --recheck --no-floppy /dev/sdX
reboot
  • I can not mount sdb because 'sdb is already mounted or /mnt/ is busy' – rosesarered Sep 15 '15 at 0:00
  • I also tried this mount /dev/sdc2 /mnt/ (sdc2 is linux partition, trying to mount sdc only will give an error same as above) till reaching /usr/sbin/grub-install --recheck --no-floppy /dev/sdc (used sdc not sdc2) All commands gave out no errors, including grub, still couldn't boot from hard disk upon restart – rosesarered Sep 15 '15 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.