0

Until yesterday I've been successfully connecting Ubuntu 15.04 to WIN7 through ethernet;

Win7 was sharing internet and Ubuntu has a shared-folder you could access through Win7.

But now it isn't working anymore,
From the Network manager on windows I can see that the ethernet connection is unidentified but I can't seem to troubleshoot in any way;

Ubuntu network manager auto-ethernet option blinks but no connection is established.

I've tried configuring Samba workgroup and creating a home group on win 7 but without any success;

edit:

if I connect through wifi network directly to router (tplink 4g router) the shared folder on ubuntu is accessible from Win (I must be something related to eth connection)

  • Can your machines ping each other? – Melebius Sep 15 '15 at 10:10
  • @Melebius how would I find address to ping ? – user2417031 Sep 15 '15 at 10:13
  • The easiest way is using command line: ipconfig in Windows, ifconfig in Linux. – Melebius Sep 15 '15 at 10:22
  • @Melebius I tried ping 192.168.0.150 -c4 in ubuntu terminal but response was 'network unreachable' (got the ping address from ipconfig on win) – user2417031 Sep 15 '15 at 10:33
  • I had also tried running nmap before that but I couldn't find anything ( nmap -sn 192.168.0.0/16 ) – user2417031 Sep 15 '15 at 10:35
1

The problem is solved with the folowing steps:

  1. Stop Network Manager /etc/init.d/NetworkManager stop
  2. Remove the Service from Run Levels update-rc.d -f NetworkManager remove
  3. Edit your interfaces file vi /etc/network/interfaces

When you are editting the network interface you can set you inteface as

Interface with DHCP

auto eth0
iface eth0 inet dhcp

or as Static Interface

auto eth0
iface eth0 inet static
  address x.x.x.x
  gateway x.x.x.y
  netmask x.x.x.x
  network x.x.x.z
  broadcast x.x.x.n

and save vi /etc/network/interfaces then do the following command:

/etc/init.d/networking restart

if you set a static addressing you must to be sure you have set DNS.

edit the following file vi /etc/resolv.conf

search example.com
domain example.com
nameserver 8.8.4.4

set your desired DNS server and save.

and there you have your network interface working again.


Aditional Resources. Here

  • on /etc/init.d/networking restart it responds stop: job failed while stopping:networking ─ start: already running – user2417031 Sep 16 '15 at 7:40
  • rebooting the system hangs checking for network-manager - after a while it goes on booting system without network configuration, reading the resource you linked to I realized my version uses upstart – user2417031 Sep 16 '15 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.