20

I'm using Pidgin and it works great. But I have trouble getting my Google Talk/Hangout account running. I'm getting the error message: "Not Authorized"

I found the following link but nothing works for me. How do I set up Google Talk in Pidgin?

I can't find the Google settings for less secure apps in my Google account.

Here are my settings:

Basic Tab:

Protocol: XMPP
Username: myUsername (without @mydomain.com)
Domain: mydomain.com
Resource: Home
Password: myPassword
Checked Remember password

Advanced Tab:

Connection security: Require encryption
Connect port: 5222 (default)
Connect server: talk.google.com
File transfer proxies: proxy.eu.jabber.org (default)
  • Note: use a combination of the answers below. You need to set up 2FA in your Google account to not have to use an insecure method. Currently, I did that from here: google.com/landing/2step Then you generate an application specific password that you replace your regular pidgin password with. Multiple answers specify this information in different ways and are useful in combination. – Andrew Sep 11 '18 at 12:33
  • Mods, don't delete my comment as an answer like you normally do, as my goal here is to not add yet-another-answer. The existing answers are sufficient in combination but they're a tangled mess. – Andrew Sep 11 '18 at 12:34
  • If you're looking for the Enterprise Hangout Chat (chat.google.com), then it's not using XMPP protocol as in talk.google.com, and thus not currently supported in Pidgin. There's a feature request in purple-hangouts – Noam Manos Nov 15 '18 at 11:35
5

I can't find the google settings for less secure apps in my google account.

When signed in to your account, go to My Account, and in the "Sign-in & Security" column, go to Connected Apps & Sites. Third option down on the right is a toggle for allowing less secure apps.

|improve this answer|||||
  • Thanks @JavaOnLunch! I found it! But it still wasn't working. I have to say the google account that I'm try to use is a gmail account with my company domain name. I finally managed to get it running. I sign in with my other "normal" gmail account (@gmail.com) and accept the certificate and then the company gmail ran fine. I hope it helps. Cheers Stefan – stevo Sep 18 '15 at 5:47
  • There is no longer a "third option down". Look at nixom's answer, which details setting up a password specific to the Pidgin instance. – nshew Jan 6 '16 at 16:10
  • 1
    This answer should be further down, the 2 Factor Authorization using App Passwords is the best solution. – AzP Aug 28 '18 at 11:38
16

people

my setting work perfect (on windows) I recommend NOT ENABLE settings for less secure apps

the trick ----> first enable 2-Step Verification in gmail settings, then add pidgin, then copy the password generate

my settings

Protocol: XMPP Username: myUsername (without @mydomain.com) Domain: gmail.com Resource: Home Password: myPassword (paste the password) Checked Remember password

check new email not.

Connection security: Require encryption Connect port: 5222 (default) Connect server: leave blank (default) File transfer proxies: proxy.eu.jabber.org (default)

show custom smileys

enjoy

|improve this answer|||||
  • 1
    This is the best answer, I think you should clean it up language-wise and regarding formatting, so it is a bit more readable. Enabling unsecure clients is NOT the way to go, you are completely right about that. – AzP Aug 28 '18 at 11:36
10

This configuration is what worked for me:

enter image description here

NOTE

You need a Connect Server: talk.google.com in the Advanced tab.

Hope this helps. Good Luck.

|improve this answer|||||
  • Not if you want encryption, which is the only truly secure method here... Looks like 2FA is needed, after all. – Andrew Sep 11 '18 at 12:31
7

From Gmail, click on your avatar on the top right, click on "My Account", then click on "Sign in security". From there, follow what you see in this image:

Sign-in security steps

|improve this answer|||||
  • How does this different from the existing answers? When you edit this answer, in order to improve it, you should fix the gramatical mistake. – Ramhound Dec 16 '16 at 18:54
5

Update: This method is no longer possible with 2FA enabled. Explore other options that don't involve allowing less secure apps.

Getting Google to accept your connection takes an extra step and depends on whether or not you have two-factor authentication (2FA) enabled.

With 2FA disabled

  1. Go to your Google account Security settings.
  2. Under Apps with account access, find the setting for "Allow less secure apps" and turn it on. This setting will not exist if you have 2FA enabled.
  3. Use the settings you've described, entering your Google account password as the password.

With 2FA enabled

  1. Go to your Google account Security settings.
  2. Under Signing in to Google, click on "App Passwords" to go to the App Passwords settings.
  3. At the bottom of the form, click on the "Select app" dropdown and choose "Other". Enter Pidgin (or whatever name you'd like) into the text box and click "Generate". Copy the generated password it provides.
  4. Use the settings you've described, but paste in the generated password from the previous step as the password.
|improve this answer|||||
  • This no longer works when 2 factor authentication is on, as 'less secure apps' are not allowed. – rjurney Jan 10 at 17:41
  • Thanks for the note, I'll edit my answer with an update. – Ian Greenleaf Young Jan 11 at 2:06
4

If you're having trouble connecting by using following one of the other answers here, note that if you're using two-factor authentication, you'll need to create an application-specific password in order to authenticate.

|improve this answer|||||
-2

look at this: https://bitbucket.org/EionRobb/purple-hangouts/wiki/Home

The difficult part is getting the oath cookie using chrome developper tools ;)

|improve this answer|||||
  • Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – MMM Mar 27 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.