2

I can't find the solution by searching the forums because I lack too much knowledge about partition tables functioning.

I've found this quite similar situation Recover or recreate partition after "diskpart clean", but he did the clean over the HDD, not the SSD as me... I don't think I did clean all over the wrong disk.

This one too: How to restore partitions and data after diskpart "clean" command?

It seems both were beyond repair.

Previous state (The Beginning)

2 disks:

  • SSD with Win7 installed, both active and boot.
  • HDD as data disk.

Both as AHCI and NTFS.

They were almost surely in MRB, not GPT (none passes 2Tb).

Motivation for the disaster (The Edge)

I forgot to reserve unallocated space for the SSD Overprovisioning.

I made a system backup with AOMEI Backupper

Then I tried:

  • Clean install:

    Leaves SSD with 100Mb bootable partition, 50Gb of unallocated for overprovisioning and the rest for OS.

  • System restore over OS partition:

    Creates another 100Mb bootable partition and I loose the 50Gb for SSD overprovisioning.

So I decided to:

  • clean the SSD
  • format it leaving aprox 50Gb of unallocated space for SSD overprovisioning
  • restoring the system backup over the now NTFS 180Gb formatted partition of the SSD

The Disaster (The Abyss)

But when I wanted to clean the SSD I carelessly did:

  • diskpart
  • selected the SSD
  • clean ALL (over the SSD, when I should've done a clean).

Anyway, I stopped it somehow. I think it shouldn't have affected the HDD at all but I tell in case it matters.

Changed my mind and:

  1. Clean installed Win 7 on SSD from bootable USB.

  2. Somehow, Win 7 did that weird thing of installing the OS on the SSD (active disk) but putting the 100Mb partition or volume of "system reserved partition" (boot disk, I think) in the HDD where I had my data!!

Now I can't see the HDD from Windows File Explorer, and in Windows Disk Manager and similar apps it appears as 1Mb unallocated (some stupid thing I did in former clean installs, I think), followed by those 100Mb of boot, followed by 1,8Gb unallocated (where my data must had been...).

(I can't post an image, lack reputation).

C: (SSD) - Boot, Active, Primary partition 

System Reserved Partition (HDD) - System, Active, Primary Partition

Is it correct that both the SSD OS partition and the HDD "System reserved partition" are Active? (I don't think so, it should be just the OS drive).

The SSD is Boot (seems OK as it contains the OS and indicates where the boot info is) and the HDD is System.

Both disks are now MBR and NTFS.

Help! (And let me cry come unto thee...) ;)

Can the former HDD data be recovered?

I have not installed or copied anything to the HDD drive. I've installed and copied everything to the OS SSD drive, lost files found included.

I tried Full Scan with LSoft Active Partition Recovery and nothing deleted was found but the Mft, boot, etc. files.

May the old partitions info files be useful (MFT, MFTMirror, etc) for recovering my old data in the HDD (the info of where each file was...)?

Much thanks in advance for any guidance.

EDIT: In case it helps anyone, I used EasyBCD to change the boot info to the SSD. It put the active and boot flag on the SSD and removed them from the HDD.

Then after ending a Super Scan on the HDD with Active Partition Recovery, I made "Delete Invalid Partition" over the current System Reserved Partition so I could try to Recover info from the 1.8Tb unallocated region.

Maybe I assigned the letter D with MiniTools Partition Wizard...

I tried chkdsk D: /B but MFT was damaged, so I used Active Partition Recovery's File Recovery and found 5 old partitions but no file except their partition info files (Mft, etc.), so there's nothing left, I imagine.

  • @Ramhound "I tried Full Scan with MiniTools Partition Recovery and Data Recovery 6.6 and nothing deleted was found but some bootlog info files." I am now trying a Super scan on the HDD with Active Partition Recovery 10, searching for NTFS. – Raúl Moreno Sep 15 '15 at 22:06
  • Of course one could have argued you should have tried that before asking this question though. – Ramhound Sep 15 '15 at 22:08
  • @Ramhound Thanks but I had already tried both a Partition recovery and Data recovery and as I said, no data was found but a some 3Mb files apparently from a former system reserved partition. So I wonder, can my data be recovered? or it must be all completely lost? I don't know why it dissapeared then Win 7 created this 100Mb system reserved partition... :s – Raúl Moreno Sep 15 '15 at 22:11
  • No; Your data cannot be recovered. You might have a small chance to send it to a data recovery service, but given that you have tried file recovery software yourself, the chances of data recovery is extremely small. You made no mention of any attempts to use file recovery software. – Ramhound Sep 15 '15 at 22:14
  • I just noticed I could not do the Undelete with MiniTools Data Recovery 6.6 because the drive didn't even appeared. I've done just scans, installed every program on the SSD, so I may not have written anything on the HDD yet. So it seems what I need now is to make that drive visible (assign it a letter? fix MBR? quick format would destroy the data i imagine...). Thank you and sorry because you're right I explained myself wrong; just said I had used 2 programs but not that I tried Partition recovery and couldn't undelete. – Raúl Moreno Sep 15 '15 at 22:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.