1

I am having issues, I believe since I upgraded my laptop from Windows 8.1 to Windows 10, on emulation. I will here give all information I can about every try of mine to emulate.

First VirtualBox. I've created several machines for different OS, but every time, in my first attempt to launch the machine and choose the .iso file, the launching would fail with this error:

NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries) (rc=-101)Make sure the kernel module has been loaded successfully.

where: supR3HardenedWinReSpawn
what:  3
VERR_OPEN_FAILED (-101) - File/Device open failed.

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help.

On the internet, people had this same issue after updating their Windows 7 (not upgrading to Windows 10). Microsoft then published this: https://support.microsoft.com/en-us/kb/3024777 and it seemed to work for them.

I also tried to install some Android emulators and if I successfully installed them, launching them was impossible.

I thought maybe the issue was coming from the BIOS, where visualization might not be enabled. Unfortunately I can't figure out how to access the BIOS (my laptop is an ASUS R500V Intel series), so I could not affirm or invalidate the theory. EDIT: I finally managed to check the BIOS, and the visualization is enabled.

I also want to add that nearly every issue mentioned here didn't exist before. I had already run an Ubuntu machine on VirtualBox and used an Android emulator before on this computer, but time has passed since the first issue appeared, and I had time to upgrade my Windows. Maybe the issue doesn't come from the upgrade, but just from an update after or before the upgrade. I can therefor think of a reason, I might have installed the problematic update, mentioned here: https://forums.virtualbox.org/viewtopic.php?f=6&t=67840. Having upgraded, I can't install the "fix update" given by Microsoft, as it is only for Windows 7 (This can also be stupid, as I had a Windows 8.1 before the upgrade).

I'm looking forward for a solution as I need a Linux system to study, and I'm not willing to install linux as a dual boot.

1
  • The pedant in me isn't going to let me not say that you are referring to Virtualisation, not Emulation. – seagull Feb 19 '16 at 1:47
3

If you're not running your recent version of VirtualBox, you should upgrade it. Make sure all boxes are properly rebooted after upgrade and run it again (sc start vboxdrv).

Then just in case re-install the VBox driver (find VBoxDrv.inf, right-click, Install again).

See also the following issues:

But since this was issue on Windows 7, but you're using Windows 8, this still can be related to some upgrade issues during the install which could broke your VirtualBox installation.

So my advice is that you to backup all your virtual machines and remove VirtualBox from your system completely, then install fresh as it clearly complains about some missing files (STATUS_OBJECT_NAME_NOT_FOUND).

1

After a night of efforts, I achieved to get the machines to work. Accessing the bios, even without changing anything, and rebooting several times before (in attempts to access the bios) have fixed the issue, as it is the only thing I did. I tried to install Andy emulator again and it failed, but I am pretty sure this is another issue, that's not related to what I was searching for.

I didn't try this on existing machines, as the issue appeared after the re-installation of VirtualBox, so no machines where left.

Hope this can help anyone that happens to have my problem, even if the fix appeared to be like magical.

1

I was trying for a solution here, but I got an idea to resolve the problem. Just installing virtualbox as an administrator resolves the problem. I am having virtualbox 5.0.10 on Windows 10 pro 64 bit. I don't know what actually happens by running as an administrator, but the problem is solved for me.

1
  • 1
    yes, reinstall as admin worked for me. – Todd Vance Nov 6 '18 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.