Why Windows 10 forgets mapped drive's credentials after reboot and how to fix it? I've seen some solutions but none of them was a fix for my problem. thanks.

  • How are you creating these mapped drives and what solutions have you seen? There are two types persistent and non-persistent mapped drives which are you using?
    – CharlesH
    Commented Sep 16, 2015 at 10:20
  • @CharlesH : I did it by GUI, mapping it and chose "save the credential"
    – Amin Sh
    Commented Sep 16, 2015 at 12:11
  • 1
    Do you get the same if you log out and back in or only with a reboot?
    – CharlesH
    Commented Sep 16, 2015 at 12:15
  • @CharlesH : Just when I reboot the windows, not logout
    – Amin Sh
    Commented Sep 20, 2015 at 11:52
  • 2
    Just out of interest can you try to map with the command instead. To do this load command prompt and type this: 'NET USE <drive letter>: \\servername\sharename /persistent:yes' obviously the drive letter is like z: and the \\servername...\\ is the UNC path your connecting too. See if that works better as you can use the persistent switch which is often more reliable than the GUI
    – CharlesH
    Commented Sep 21, 2015 at 7:10

8 Answers 8


Use credential manager in Windows to remember the username and password for your Drive if it doesnt remember it automatically.

Go to Start Control Panel User Accounts and Family Safety Credential Manager

On the right hand side, right below where it says "Windows Credentials" Select "Add a Windows Credential".

Enter your Server name or IP in the first box.

User Name in the second box and your password for the server in the third box.

source:Microsoft Answers Feedback Forum

  • 1
    Thanks. Still relevant with Windows 10... For me, with Win10 Enterprise, it's Control Panel > User Accounts > Manage your credentials > Windows Credentials.
    – pascal
    Commented Sep 23, 2021 at 9:46
  • 1
    In my case (being on a computer associated to a domain) it was necessary to put the username as domain\username, instead of just the username.
    – hanjo
    Commented Jul 28, 2022 at 15:06
  1. Win+R
  2. cmd
  3. enter
  4. net use <drive letter>: \\servername\sharename /persistent:yes

Don't use an administrator command prompt. A regular command prompt is best.

Thanks to @charlesh above.

I could not get the drive mapping to save when I used the utility provided by the NAS manufacturer, but this worked instead.

  • The reason regular command prompt is "best" is that the credential manager is per user. If you do it as admin then only that admin account has the credentials. If you wanted to store credentials for a service account, you would run the command as the service account to store the credentials there.
    – HackSlash
    Commented Feb 6 at 19:58

You can force adding to the credentials with cmdkey :

cmdkey /add:YourServer /user:YourUsername /pass:YourPassword

You can also list the currently stored credentials with

cmdkey /list

See cmdkey /help for more options and details.


I was having this problem with a Windows Server contacting an Azure file share. To fix it, I:

  1. Deleted the file share using net use W: /d
  2. Deleted its entry in Windows Credentials
  3. Reestablished the connection using File Exporer, ticking Reconnect at Sign-In and Remember my credentials (when entering the password).

If this happened after the Windows 10 v1809 update then the issue is probably that your credential manager isn't updating and has the old "homegroup" reference which is not longer supported in this new version.

simply remove each of the Windows credentials concerned and re-establish them (i.e. connect to network share and enter username/password and check "remember me".


I had the same issue with Windows 10 not accessing mapped drives on a Synology NAS. During the troubleshooting process, I found my boot drive was set up as MBR rather than GPT. I converted to GPT and the problem disappeared.


Windows 10 seems to remember your first credentials to the server of your mapped drive. So if you delete the mapped drive and reinstall/connect to it again after a reboot, it will revert to your original credentials after your new reboot. Even if you chose to save your credentials by using the GUI in your new attempt connecting to your server as a mapped drive (after having deleted them all, which drove me nuts).

As with a previous answer, use the windows credentials manager to add/delete/edit your credentials to your server. However, you don't need to add new or delete existing credentials since you can just as easily edit your invalid credentials. You can edit both username and password (I couldn't comment the previous answer, not enough points yet). Go to:

windows+S / Control Panel (original, not windows 10 version) / User Accounts / Credential Manager / Windows references

There you will see the reference to your server (in a list of saved credentials). After unfolding you will see the stored username and an option to edit both user name and password.

Your user name will be something like : PcName\ServerUserName

Change both your serverusername and password if needed and all your mapped drives will work again.

This worked for me with my qnap after changing the username and password on my qnap.


The cause/fix for the same problem in my setup was: Do NOT use a fully qualified servername. So do not "mysamba.intern.me" but instead just "mysamba". Otherwise the credentials won't be stored in the Credentials Manager. Even if you enter them manually with 'cmdkey' or CredentialsManager GUI, it won't be used for some reason.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .