15

Why Windows 10 forgets mapped drive's credentials after reboot and how to fix it? I've seen some solutions but none of them was a fix for my problem. thanks.

  • How are you creating these mapped drives and what solutions have you seen? There are two types persistent and non-persistent mapped drives which are you using? – CharlesH Sep 16 '15 at 10:20
  • @CharlesH : I did it by GUI, mapping it and chose "save the credential" – Amin Sh Sep 16 '15 at 12:11
  • 1
    Do you get the same if you log out and back in or only with a reboot? – CharlesH Sep 16 '15 at 12:15
  • @CharlesH : Just when I reboot the windows, not logout – Amin Sh Sep 20 '15 at 11:52
  • 2
    Just out of interest can you try to map with the command instead. To do this load command prompt and type this: 'NET USE <drive letter>: \\servername\sharename /persistent:yes' obviously the drive letter is like z: and the \\servername...\\ is the UNC path your connecting too. See if that works better as you can use the persistent switch which is often more reliable than the GUI – CharlesH Sep 21 '15 at 7:10
7

Use credential manager in Windows to remember the username and password for your Drive if it doesnt remember it automatically.

Go to Start / Control Panel / User Accounts and Family Safety / Credential Manager

On the right hand side, right below where it says "Windows Credentials" Select "Add a Windows Credential".

Enter your Server name or IP in the first box.

User Name in the second box and your password for the server in the third box.

source:Microsoft Answers Feedback Forum

| improve this answer | |
6
  1. Win+R
  2. cmd
  3. enter
  4. net use <drive letter>: \\servername\sharename /persistent:yes

Don't use an administrator command prompt. A regular command prompt is best.

Thanks to @charlesh above.

I could not get the drive mapping to save when I used the utility provided by the NAS manufacturer, but this worked instead.

| improve this answer | |
1

I was having this problem with a Windows Server contacting an Azure file share. To fix it, I:

  1. Deleted the file share using net use W: /d
  2. Deleted its entry in Windows Credentials
  3. Reestablished the connection using File Exporer, ticking Reconnect at Sign-In and Remember my credentials (when entering the password).
| improve this answer | |
0

If this happened after the Windows 10 v1809 update then the issue is probably that your credential manager isn't updating and has the old "homegroup" reference which is not longer supported in this new version.

simply remove each of the Windows credentials concerned and re-establish them (i.e. connect to network share and enter username/password and check "remember me".

| improve this answer | |
0

I had the same issue with Windows 10 not accessing mapped drives on a Synology NAS. During the troubleshooting process, I found my boot drive was set up as MBR rather than GPT. I converted to GPT and the problem disappeared.

| improve this answer | |
0

Windows 10 seems to remember your first credentials to the server of your mapped drive. So if you delete the mapped drive and reinstall/connect to it again after a reboot, it will revert to your original credentials after your new reboot. Even if you chose to save your credentials by using the GUI in your new attempt connecting to your server as a mapped drive (after having deleted them all, which drove me nuts).

As with a previous answer, use the windows credentials manager to add/delete/edit your credentials to your server. However, you don't need to add new or delete existing credentials since you can just as easily edit your invalid credentials. You can edit both username and password (I couldn't comment the previous answer, not enough points yet). Go to:

windows+S / Control Panel (original, not windows 10 version) / User Accounts / Credential Manager / Windows references

There you will see the reference to your server (in a list of saved credentials). After unfolding you will see the stored username and an option to edit both user name and password.

Your user name will be something like : PcName\ServerUserName

Change both your serverusername and password if needed and all your mapped drives will work again.

This worked for me with my qnap after changing the username and password on my qnap.

| improve this answer | |
New contributor
JeeHaa is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.