4

Not sure what is causing this but it appears my Wlan won't connect any longer after a recent update of ubuntu:

uname -a
Linux p859116 3.16.0-49-generic #65~14.04.1-Ubuntu SMP Wed Sep 9 10:03:23  UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I am running NetworkManager. It appears to authenticate successfully and then de-authenticate (?). I see somethign there about DFS Master region being unset. And then "deauthenticating by local choice" (what ever that means). Any clues? Thanks in advance. Here is what I see in dmesg:

wlan0: authenticate with 20:3a:07:9e:16:3f
[  123.575097] wlan0: send auth to 20:3a:07:9e:16:3f (try 1/3)
[  123.623343] wlan0: authenticated
[  123.623517] wlan0: waiting for beacon from 20:3a:07:9e:16:3f
[  123.729736] wlan0: associate with 20:3a:07:9e:16:3f (try 1/3)
[  123.731909] wlan0: RX AssocResp from 20:3a:07:9e:16:3f (capab=0x11    status=0 aid=1)
[  123.735668] wlan0: associated
[  123.735686] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  123.735749] cfg80211: Calling CRDA for country: US
[  123.737333] cfg80211: Regulatory domain changed to country: US
[  123.737335] cfg80211:  DFS Master region: unset
[  123.737336] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  123.737337] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm), (N/A)
[  123.737338] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm), (N/A)
[  123.737339] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s)
[  123.737340] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s)
[  123.737341] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s)
[  123.737342] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm), (N/A)
[  123.737343] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[  147.246275] wlan0: deauthenticating from 20:3a:07:9e:16:3f by local choice (Reason: 3=DEAUTH_LEAVING)

iwconfig:

 eth0      no wireless extensions.

 wlan0     IEEE 802.11abgn  ESSID:off/any  
           Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
           Retry short limit:7   RTS thr:off   Fragment thr:off
           Power Management:off

 lo        no wireless extensions.
1
  • Relevant: bugs.debian.org/cgi-bin/bugreport.cgi?bug=683407 In particular, the comment: "the correct error is not being surfaced...wpa_supplicant returns a failure to network manager, which responds by closing the connection. Hence the "disconnected by local choice" message that you see in dmesg" There are likely a number of causes and solutions to this issue. E.g., other suggested fixes (worked for some, not others) include adjusting power settings: sudo iwconfig wlan0 power off
    – michael
    Sep 22, 2015 at 13:17

1 Answer 1

4

This seems rather common after an update. Generally, it is because the REGDOMAIN variable in /etc/default/crda is not set, or it is improperly set.

First, issue these two commands,

   sudo iw reg set US
   sudo sed -i 's/^REG.*=$/&US/' /etc/default/crda

then reboot and try whether now your wifi works fine. Should it not, you may try looking at the output of this shell script, http://ubuntuforums.org/showthread.php?t=370108.

3
  • I am having the same problem. Setting REGDOMAIN to my country did not help. Ubuntu 16.04 on a Thinkpad X230, with power management on wireless card turned off.
    – January
    Jul 10, 2019 at 11:32
  • @January You should give me something more to work on. Can you please tell me what is the output of the shell script linked above? Jul 10, 2019 at 16:34
  • OK, I got it: the default authentication method chosen by ubuntu NetworkManager for the wireless I was trying to access (eduroam btw) was incorrect. Ubuntu chose tunneled TLS + MSCHAPV2, but that did not work; two other options worked: either PEAP or tunneled TLS + PAP. However, the symptoms in dmesg were identical to those here.
    – January
    Jul 11, 2019 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.