0

I'm using Fedora 22 which is now using systemd.

What bothers me currently is that the journald seems to be ignoring my configurations. Here's my /etc/systemd/journald.conf.

[Journal]
Storage=persistent
Compress=yes
SystemMaxUse=128M
RuntimeMaxUse=64M
ForwardToSyslog=no
ForwardToKMsg=no
ForwardToConsole=no
ForwardToWall=no

I set Storage=persistent but I have to create /var/log/journal manually and restart systemd-journald to enable logging. (Otherwise journalctl will show no entries.) This looks like the default Storage=auto setting but not mine.

I set ForwardToWall=no but I can still see a mass of logs in TTYs. This also looks like the default ForwardToWall=yes.

How can I make journald follow my custom configurations?

  • Silly maybe but I have to ask for: did you restart the service? systemctl restart systemd-journald.service – Hastur Sep 17 '15 at 16:54
  • @Hastur Of course, I even rebooted my machine. – Frederick Zhang Sep 17 '15 at 23:19
  • For decreasing amount of logs on your TTY see this answer – VL-80 Nov 6 '15 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.