I am currently using a system I cannot change that writes tar files to a floppy disk.

I need to read/write the same type of disk on a windows machine.

The command used to create the disk in Linux is: "tar -cf /dev/sdb myfile"

Unfortunately, windows does not recognize disks created like this. I get the "disk not formatted" error when I plug in the usb floppy drive. (Expected, as it is not an actual filesystem)

I am trying to use 7zip command line to access the file, by typing "7z.exe -l A:" The floppy light comes on, but no archive is found. Is there a way to allow some software like 7zip to see the actual raw floppy contents? Because it IS a tar file, but has no mountable filesystem.

| improve this question | | | | |

I do not think it's possible via command line, but I was able to read an archive tarred (is that a word?) directly to device (I used your tar command to write to USB) using 7a File Manager (GUI). You'd need to use special prefix to address device directly:

The "\\.\" prefix will access the Win32 device namespace instead of the Win32 file namespace. This is how access to physical disks and volumes is accomplished directly

Syntax I was able to use to get access to my test archive was 7zfm \\.\f:\ (I do not have floppy, so I used USB instead) - so I expect 7zfm \\.\A:\ should work for you. You may also put it as path after you start GUI, or use \\.\ to escape to device namespace and then select your drive.

| improve this answer | | | | |
  • Wow. this is the closest I have seen so far! I was able to read the file via the 7zip gui, but not write. And as you mentioned, the command line 7z was unable to access it. So close. Do you know a commandline tool that might be able to interact a little better with this device namespace? Also, SUPER helpful on the \\.\ information. I had no idea something like that existed -- you have given me a new avenue to explore. – izzmit Sep 17 '15 at 21:47
  • @izzmit I have not read your question carefully enough (that you also want to create/write that way)... I think Cygwin (cygwin.com) is your best bet then. – wmz Sep 17 '15 at 22:57
  • I ran into an issue downloading Cygwin @ my work, so I will tackle that later. I did try GnuWin32 LibArchive (gnuwin32.sourceforge.net/packages/libarchive.htm), using the command: "bsdtar.exe tf \\.\A:\" The floppy drive activates (attempt to read) but the program gives "Invalid argument". I will post back here after I try Cygwin. – izzmit Sep 21 '15 at 20:47
  • Cygwin works! Actually, I installed Cygwin and was able to directly access the bsdtar.exe executable without starting Cygwin. Now I can check a tar floppy disk with "bsdtar.exe -tf /dev/fd0" – izzmit Oct 12 '15 at 16:44
  • 1
    I'm pretty sure the problem is the backslash should not be on the end of the path. – Joshua Apr 29 '17 at 19:38

I'm pretty sure you can create a floppy like this in Windows by using 7zip to create the tar file you want, and then write it to floppy with rawwritewin-0.7 (you might have to rename from .tar to .img)

I haven't tried this myself.

(Perhaps it would be a good idea to zero out the floppy first.)

You could probaby read the disk in the same manner. Dump it to .img with rawwritewin, rename it to .tar and open with 7zip.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.