1

I tried to install a windows 10 DVD on my laptop with windows OS, after formatting the OS drive, I got the "MBR drive" error, so I should convert it to GPT, but I have no OS on laptop, and there is the other two drives D, and E, which I don't want to erase.

I know I can convert it by "AOMEI Partition Assistant" but I couldn't get it to work on an old XP / Win7 live disk I have.

EDIT:

the error I get:

Windows cannot be installed on this disk. The selected disk is of the GPT Partition style.

In my Lenovo G50 's bios there is these boot options:

Boot Mode: Legacy Support => UEFI First / Legacy First => USB Mode: ON/ OFF

Boot Mode: UEFI => USB Mode: ON/ OFF

Edit2

I did test Windows 8, 7 and XP, same error. I tried a Live disk with some partitioning application on it, but it couldn't do the trick w/o data loss.

  • 4
    Whatever else you do, you must back up your sensitive data first. – AFH Sep 17 '15 at 22:38
  • 1
    Can you mention what exactly was the MBR drive error? If your current drive is MBR partition scheme then enable CSM (Compatibility Support Mode) or Disable UEFI whichever way it's configured in your firmware setup screens and install Windows 10 – patkim Sep 17 '15 at 23:56
  • 2
    possible duplicate of How can I convert a MBR partition to GPT without loss of data? – Ramhound Sep 18 '15 at 0:41
  • 1
    @Ramhound that link is for OSX, not Windows. – Moab Sep 18 '15 at 22:05
  • 1
    @Brainiac ". I tried a Live disk with some partitioning application on it" not all software can do a non destructive conversion. – Moab Sep 18 '15 at 22:06
2

If you prefer to keep your hard drive the way it is, you can disable Secure Boot on your motherboard, then try installing windows the same way you did. It should work without needing to convert to GPT. If you prefer to convert your hard drive, this question has already been answered elsewhere.

The reason why Windows refuses to install on a MBR drive is because Secure Boot is enabled on your motherboard. When Secure Boot is enabled, any software that is set to boot must be signed by a Certificate Authority in order for the motherboard to authorize it. That includes the installation media and the operating system once installed.

The error occurs because the Windows installation detects it is being ran through Secure Boot and knows it must require to be installed on a Secure Boot compatible hard drive, which is GPT. Once the installation is done, the motherboard boots from the Windows partition but only after Secure Boot verifies the signature of the operating system on that partition.

Motherboard type = BIOS and EFI
BIOS uses MBR.
EFI uses MBR and GPT.
Secure Boot which is a feature of EFI can only be used with GPT.

Enabling CSM on a motherboard is basically running the motherboard as a standard BIOS motherboard, thus disabling Secure Boot.

|improve this answer|||||
  • If I correctly understand, Secure Boot is an element of UEFI and may also be optional (exclude OEM Windows 8 & above PC/Laptop) . Disabling Secure Boot may not necessarily disable UEFI. However Disabling UEFI (Or Switching to CSM) automatically disables Secure Boot. As long as UEFI mode is enabled, regardless of secure boot Windows 8 and above shall default install in EFI Mode with GPT partition scheme. So in such a case it shall fail to install if it detects MBR disk. – patkim Sep 18 '15 at 4:50
  • User Brainiac may now need to explore some ‘System Rescue Disks’ that have on the fly tools which can do the disk partition scheme conversion without loss of data. I am not sure if there are any but just commenting it as a possibility. Or if user knows the specific tools, it can be explored if that vendor also offers bootable disk version (preferably with UEFI boot support) so that system boots off that disk in absence of existing OS and does the needful tasks. – patkim Sep 18 '15 at 4:50
1

I finally was able to do the trick with a boot-able partitioning software (MiniTool Partition Wizard) and it was without data loss, fortunately.

Just made a boot-able usb flash and converted the HDD to "GPT".

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.