5

I just upgraded from Windows 7 to Windows 10, and now, every time I open a file type I haven't yet opened in Windows 10, I get this dialog:

How do you want to open this file?

I understand that I can check the "Always use this app to open these files" box to get Windows to shut up about that particular file type, but with literally thousands of file types on my system and hundreds of programs governing them, I'll be doing this for years and years to come. How can I get Windows 10 to shut up and just let me keep using my existing file associations?

  • So u dont want the open with dialog with suggested apps everytime?or u just need to associate default files with respective tool – BlueBerry - Vignesh4303 Sep 18 '15 at 4:47
  • I don't want the dialog. – blackwind Sep 18 '15 at 5:27
  • 1
    "literally thousands of file types on my system" - unlikely. I have less than 500 registered file types on a 5 year old PC. – DavidPostill Apr 12 '16 at 20:49
2

There seems to be the solution to similar to yours issue. You should be able to disable this functionality by following the instruction provided in the link. This is only applicable if are on Pro, Enterprise or Education editions.

  1. Open Group Policy by typing gpedit.msc in Run
  2. Expand the Computer Configuration -> Administrative Templates -> Windows Components and open File Explorer
  3. In File Explorer choose Do not show the 'new application installed' notification.
  4. That's the part where it gets a bit weird:
    • To Enable the notifications choose either Not configured or Disabled
    • To Disable the notifications choose Enabled

Check out the snapshots below. Group policy window Configuration window Hope this helps.

| improve this answer | |
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. It's also an answer to a different problem, so it doesn't answer the question. – DavidPostill Apr 12 '16 at 20:46
  • For some reason my win 10 install seemed to permenantly think it had a new jpg viewer installed, so just looped popping up the choice dialog. This was the only way I found to fix it – Phil Jun 3 '17 at 21:05
0

Open the Windows 10 Control Panel, then click Programs, then Default Programs. The first two entries on this list are what you’re interested in.

If you’d like to set a single program as the default for all the types of files it’s capable of opening, click set your default programs. This screen opens a list of your installed programs in the column on the left. Click a program in the left column, then click set this program as default to apply all of the file type associations that the program includes.

Another option, you may see on the screenshot you attached, is to use the checkbox at the bottom of the dialog Always use this app to open .... It will ask you once, and will remember you setting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.