0

I have a PC for professional use, that is used mostly for coding web pages and some low res videos. It is equipped with 3 x 24" monitors.
Since I connected the third monitor to DVI with a DVI to HDMI adapter it started flickering from times to times.

My configuration:

Operating System
Windows 7 Ultimate 64-bit SP1
CPU
AMD FX-8320 Vishera 32nm Technology
Motherboard
MSI 760GA-P43(FX) (MS-7699) (CPU1)
Graphics
2047MB NVIDIA GeForce GTX 760 (MSI)
Monitors
S24C750 (1920x1080@60Hz)
S24C750 (1920x1080@60Hz)
S24B370 (1920x1080@60Hz)

All monitors to this configuration are Samsung and my available ports are 1 HDMI, 1 DVI-I, 1 DVI-D and 1 Display Port (not used).

Also I use display fusion to expand my taskbar.

Any suggestions to fix this flickering?

Edit
My flickering monitor has 2 HDIM inputs.
I moved the cable from input 1 to input 2 but still flickers. By the way I had an other monitor flickering and once I moved it from DVI to HDMI it stopped, but I have only one HDMI available.

9
  • Before you fix it, you need to figure what is causing it. Swap the monitor input to another one to see if the issue moves. If the monitor continues to flicker, it has to do with the monitor. If the flickering moves with the swap, it is likely a video card issue.
    – CharlieRB
    Sep 18 '15 at 12:22
  • The card is new, and with the old one there was this problem. The monitor has two HDMI ports and I changed the cable from 1 to 2. So I am waiting to see the results. Sep 18 '15 at 12:24
  • Until we know those results, there really isn't any way to answer your question.
    – CharlieRB
    Sep 18 '15 at 12:26
  • Yes I know I will inform you with an update to my post. Sep 18 '15 at 12:27
  • @CharlieRB Problem persists. Sep 18 '15 at 12:32
0

I am sure you are well past this issue now, however I have the same problem. Posting this fix for anyone that has the same problem.

After a lot of troubleshooting, the issue appears to be related to the "magic bright" feature.

Press the "Menu" button, select "magic bright", and move the display type to "standard". I am unsure which other modes will prevent the screen flickering on and off, however I know that the "cinema" mode was the mode that caused my S24C750P's (I have 5 of them) to flicker or randomly turn off.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .