[Update: The short answer is, if an application is the third thing on your taskbar, press WindowsKey+Shift+3 to open a new instance. Hooray!]

I have Chrome and Cygwin on my taskbar. Chrome's shortcut is Ctrl-Alt-C (as set through right clicking the icon and putting Ctrl-Alt-C into Chrome -> Properties -> Shortcut Key). Cygwin's shortcut is Ctrl-Alt-T.

When I press Ctrl-Alt-C, I get a new Chrome window. Great! It's as if I had shift-clicked on the Chrome icon.

When I press Ctrl-Alt-T, I get a Cygwin window the first time, but after that I just get focused on the Cygwin window, as if I had simply clicked on the Cygwin icon and not shift-clicked. Cygwin seems unable to have more than one instance open. I can still shift-click the icon to get more instances.

I've tried with different keys than Ctrl-Alt-T and got the same behavior. Strangely, I've twice managed to get it into a state (via just clearing and setting the shortcut key over and over) where a shortcut would open multiple instances -- but it was Ctrl-Alt-G both times, which doesn't make sense to my brain which has been trained to use Ctrl-Alt-T for years. Ctrl-Alt-G usually behaves just as poorly as Ctrl-Alt-T, except for the two times when magically it started behaving properly.

So I'm thinking this is a Windows 7 bug (which has existed since Windows XP at least), but I'm hoping someone knows something I don't!

  • BTW I got here looking for a solution to identical behaviour exhibited by Excel.
    – Robino
    May 7, 2014 at 15:34

2 Answers 2


From what it looks like, Chrome has a separate way of handling the keyboard shortcut. Trying this on XP, certain applications are opening new instances however most are not. I think it has to be coded into the application to handle the signal differently.

In Windows 7, there is an easy way to open multiple instances of an application though. Simply hold Shift and click on an existing instance of the application in the taskbar.

You could also use AutoHotkey for this. Simply map the shortcut to run the executable:

^!t::Run C:\Cygwin\bin\bash.exe

Make sure you've disabled the shortcut in Cygwin's shortcut properties first though. You'll need to change the executable path according to your environment.

  • Thank you John! It seems strange that occasionally I got Cygwin into a state where it did open multiple windows. Also, while I don't want to use the mouse to Shift-click, on a whim I tried Win-Shift-3 (Cygwin is the 3rd item in my taskbar) and it opens a new instance! W00t! Jan 19, 2010 at 0:44

As far as launching applications on taskbar using keyboard shortcut you could use ⊞ Win + N, with N being the place of application on taskbar. For an application that is right next to the Windows Orb, N would equal 1.

To cycle between programs, use Alt + Tab.

  • Consider adding Win + Alt + N which brings up the equivalent right-click menu of that taskbar item.
    – Ben
    Dec 18, 2019 at 11:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .