1

I have a custom built computer with an ASUS R9 290, an ASUS Maximus VI Hero motherboard, and an an Intel Core i7 4770K running Windows 8.1 64-bit.

Recently I decided to wipe all my data to “start fresh.” After I had done so and had installed Windows, it was showing the screen in very bad quality. I couldn’t turn up my monitor to its native resolution.

So I tried to install the latest AMD Catalyst drivers, but it crashed as soon as the video driver part started installing. Afterwards, I went to the ASUS site and tried installing their drivers. It didn’t work the first time, but when I disabled the Catalyst Control Center install, it worked.

However, after about a minute—or when a program opens—the computer just blackscreens. Sometimes it recovers and sometimes it gives me a frozen screen with random purple dots. I don’t know what to do, can someone give me pointers?

  • Is there anything else that you have tried? Have you attempted to re-install the AMD Catalyst drivers a second time? Also, what do you mean by 'very bad quality' in terms of the monitor? Were there any lines/patches of solid colours/areas not being displayed? – pratt_korp Sep 27 '15 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.