After installing Windows 10, while typing in the Start menu, I was able to search for some basic programs and system elements like Control Panel. After some initial setup and installing some applications (i.e. Visual Studio, Virtual Box), however, it was impossible to find them.

I tried rebuilding my search index, but to no avail. I followed another suggestion -- deleting all files in %ProgramData%\Microsoft\Search -- but it only made things worse; I could no longer search for basic apps or system components.

How can I get Windows search working properly?

1 Answer 1


I managed to fix the issue and I think this answer can be relevant for some of the problems reported in semi-related questions. I want to tell you everything I know with as many details as possible so if my fix is not working you can come up with something reading this. That's why I wrote tl;dr section.


re-enable UAC / EnableLUA. Mark %ProgramData% folder as not readonly, verify permissions, also try Windows 10 Search can't find ANY applications. Even calculator

My exact steps

  1. Installed Windows (upgraded from Windows 8.1 with total purge of system drive)
  2. Performed my initial setup ritual* (this was the cause - see below)
  3. Installed some new apps
  4. Noticed search is not working properly
  5. Tried rebuilding the index to no avail
  6. Deleted all files in Windows Search directory (made things worse)
  7. Tried rebuilding the search index once again (no effect at all)
  8. Run windows search troubleshooting And this was the first I got some valuable feedback: Incorrect permissions on Windows Search directories - (red cross) Not fixed.


I verified permissions and folder attributes of the aforementioned folder and everytihng seemed to be OK. So I thought "ah, what the hell" and enabled UAC, rebooted Windows and was shocked by start menu search correclty without even rebuilding index etc.


My initial setup includes many steps like installing web browser, email client, VPN etc. and

Disabling UAC globally (EnableLUA->0 method) Why? I am not in danger, Skyler. I AM THE DANGER!

I fixed Windows, made workarounds for Windows and .NET bugs, hacked windows kernel etc. so I find UAC very, very, very annoying because I am not your normal, everyday user. I don't need to be protected by system, it is the other way around. I am aware why metro apps won't work in this mode and I understand this totally. As far as I know many people disable UAC like that

Very important thing is I did this in Windows 8.1 and didn't experience such problems

After looking at some other questions here, at Super User I found one asking about indexing on SSD in Windows 8, I remembered Windows 10 Control Panel Search and Indexing options and launched Windows 8 to see if I can give a step by step instructions how to resolve his issue using these settings. But turns out this is new in Windows 10 (I never really looked at all elements of Control Panel, I rather used mmc). After some searching (oh, irony!) I found out that the new indexing mechanism in Windows 10 doesn't work with UAC disabled, until this is fixed I have to update the index after installing new apps by enabling and re-disabling UAC.

If I have time I will try to come up with workaround if this will not be fixed by Microsoft.

  • Wow, just wow. Thanks for the clarification!
    – kipusoep
    Feb 28, 2016 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.