3

I have a Dell Inspiron Ultrabook running Windows 8.1 (64-bit). In File Explorer, I click on Drive C Properties -> Tools -> Optimize. There I see 4 drives listed as follows:

  • OS (C:) -- OK (0% fragmented)
  • PBR Image -- OK (0% fragmented)
  • WINRETOOLS -- OK (0% fragmented)
  • \\?\Volume{6e84d74b-fb3c-4a0e-9662-694d4192fb09}\ -- Needs optimization (94% fragmented)

If I select the "...{6e84d74b..." drive volume, and click the Optimize button to try to run Defrag on it, nothing happens except that an error appears in Event Viewer -> Windows Logs -> Application Log. The error that gets logged there is as follows:

Error, Event ID 257, Source: Defrag, The volume \\?\Volume{6e84d74b-fb3c-4a0e-9662-694d4192fb09}\ was not optimized because an error was encountered: The parameter is incorrect. (0x80070057)

Note that this system has two entries in Device Manager under Disk Drives as follows:

  • SSD PM830 mSATA (Disk 1, with 1 volume listed)
  • ST500LT012-9WS1 (Disk 0, with 5 volumes listed)

Unfortunately, I don't know how to tell if the "...{6e84d74b..." drive volume resides on the SSD (Disk 1) or the HDD (Disk 0). If there's a way to figure that out, I'd like to know.

So, I actually have several questions here:

  1. What is this drive volume used for; and does it really matter that it's fragmented?
  2. If it does matter, then how can I go about defragging it?
  3. In the logged error event, exactly which "parameter" is incorrect?
  4. How can I tell which physical drive this volume is located on?
1
  • Use mountvol to mount the volume and give it a drive letter.
    – DavidPostill
    Sep 19, 2015 at 22:57

1 Answer 1

1

1. What you see there is just an unmounted partition. Easier said, a partition without a drive letter, so we don't know what it's used for. Maybe it is a recovery partition.

2. Right click on your windows icon and open Command prompt (Admin). Type mountvol J: \\?\Volume{6e84d74b-fb3c-4a0e-9662-694d4192fb09}\. Only use J: if it isn't used already. This command will mount the partition and you will see it in the explorer. Now you can try to defrag again.

3. I don't really know. Maybe because it tries to access the partition through \\?\Volume{6e84d74b-fb3c-4a0e-9662-694d4192fb09}\ and not through a drive letter like J: and that is causing the command to fail

4. Open Disk Management after mounting the partition and you will see to which hard drive the partition belongs.

5
  • Your suggestion for mounting the volume worked -- at least as far as being able to see the contents. It appears to be some kind of recovery partition (449 MB total, of which 312 MB is used). But trying to Defrag it still fails with the same Event Log error. So it's still 94% fragmented. Any other ideas?
    – Tom-T
    Sep 19, 2015 at 23:15
  • Now that I used "mountvol" to assign a drive letter to this partition, what command syntax do I use to dismount the partition -- i.e. remove the drive letter?
    – Tom-T
    Sep 19, 2015 at 23:24
  • You should not defrag a recovery partition. It is not a problem that windows shows 94% fragmented, that is totally normal. I would recommend to turn off the defragment of this partition. To do so open Defragment and Optimize Drives and search for the drive letter, then click turn off.
    – schacker22
    Sep 19, 2015 at 23:31
  • To dismount the partition use this: mountvol J: /p
    – schacker22
    Sep 19, 2015 at 23:33
  • Thanks. The "mountvol J: /p" worked. Drive J is gone again. I'll take your advice; and simply turn off defragmentation of that partition. That seems to be the simplest solution. It's curious though that Dell shipped the system with optimization turned on for that un-lettered volume in the first place though. All that accomplished was to periodically generate those Event 257 errors in the Application Log each time the scheduled system defrag kicked off. Kind of stupid on their part.
    – Tom-T
    Sep 19, 2015 at 23:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .