5

Windows 10 just installed. A 4K laptop with standard 2k (HD) external monitor attached with HDMI cable.

Set DPI scaling of 200% for the internal display and 100% for the external. But - when an application is launched, it is displayed on the internal display correctly, and when moved to the external display - even though the scaling is correct, the rendering is poor = blurry (!!). So unless I am biased due to the 4K display, it appears that windows renders to the higher 4K internal display and then downscales to 2K (by some crude downsampling and some antialiasing possibly), instead of rendering directly to 2K.

Is this right? Any suggestions to force windows to render directly to 2k?

[BYPASSED] Installed an external 4K monitor and problem solved (obviously...).

1

Dynamic scaling is only a new thing, Windows 7 let you set a global scaling factor (applies to all monitors) and this is what MOST programs still use. So when the program launches, it picks one scaling (probably from which-ever monitor Cortana is on) and it stays like that. so when you move it to the other screen, as you say - it crudely deforms the ui. This is because the program is not "aware" of the dynamic scaling, so it doesnt change, and therefor Windows wrecks it.

A good example of this is the classic Adobe products that never got added to Creative Suite DC.

Solutions:

  1. If you haven't already - update your computer to the Creator's update (v1703) just go to Windows update and click the text which says "get the update now instead". They have made a lot of work to make the scaling a bit better.

  2. The link above has a screenshot of how you can toggle DPI-awareness support in the .exe's properties dialog. You will need to do this for each non-dpi-aware exe.

  3. Set all monitors to the one scaling. This is personally what I do (100% scale across 3 monitors) - it's squinty, but there is less shenanigans with having to configure each program to different dpi-aware settings.

  4. Of course, changing the MAIN monitor to the one you use the most, is the simplest solution. So now, non-scaling apps will initially scale to this main monitor, and you only get the blurriness when it is moved away again.

1

I had the same issue and it was very frustrating. My solution was to set the external monitor to my main display. That way I was able to keep my laptop's built-in display set to 250% (Recommended) Scale and Layout with Resolution of 3840 x 2160 (Recommended) and my external monitor (Samsung LED S27D590 listed as Digital Television) set at 100% with Resolution of 1920 x 1080 (Recommended.) This also restored the icons in SQL Server Management Studio to a readable size. The had been almost too tiny to read. Excel, Word and Visual Studio had also been blurry... no more. Settings seem to get messed up when undocking or disconnecting HDMI. Hope this helps someone.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.