0

I have been able to edit the environment variables in the past in Windows 7 by selecting “Advanced system settings” and clicking on “Environment Variables” and selecting a variable – in particular, PATH – and editing the value and adding the required directory to it, like C:\Program Files\7-Zip, but I am unable to edit the PATH in Windows 10 to add this directory.

I have also tried a Windows search and navigating to “Edit the System Environment Variables” and clicking on PATH, but still I am unable to type in this field as it’s not clickable. I have also deleted a directory in the path but still it wouldn't let me type in the field.

  • It would help if you gave an indication of the Windows versions where it worked and where it now doesn't. – AFH Sep 20 '15 at 22:25
  • I've tried this in W10 and it all works as before. My account type is Administrator, but otherwise I did nothing special, accessing it as previously through This PC -> Right-click -> Properties. If you are not an Administrator, you can add a new PATH variable to your User variables, and any entries here will be added to your PATH after the System entries. – AFH Sep 20 '15 at 22:53
  • (I didn't see Dr Pippik's answer until I had made my comment, after checking out the positioning of the User path in the composite variable). – AFH Sep 20 '15 at 23:00
  • @AFH I am currently the system admin and it doesnt let me edit the 'Path' Variable. I added a new variable and it overwrites the previous path variable – BuzzLightYear Sep 20 '15 at 23:08
  • 1
    Yes, I saw your comments below Dr Pippik's answer. I am at a loss to explain it, but I can suggest a work-round. Since the PATH variable is used mainly in a CMD context, you can add a batch file to run every time CMD starts, following the answer here. You can then put PATH %PATH%;{ExtraPaths} into the start-up batch file. – AFH Sep 21 '15 at 12:11
1

There are two sets of Environment Variables, that of the user and that of the system. By default, older Windows OS accounts were set up with Administrator privileges, but newer versions, such as Windows 8, may create safer user accounts with fewer rights, such as access to System variables.

*Environment Variables*

You have two choices, if you need to edit PATH:

  1. Log on as Administrator, and edit System PATH.

  2. If all that you need to do is to add to the PATH, then simply create a new user Environment Variable named PATH. The full PATH is the union of both sets of variables, System and User. In most cases, this is easier and safer than editing the System PATH.

  • I am currently logged in as Admin as that's the only account on my system but still cant edit this. I tried creating a new variable called path but this overwrites the current Path variable even when the name of the new variable was changed to something else. Why is that? Thanks for the reply – BuzzLightYear Sep 20 '15 at 22:54
  • You need to add to the end of the current path variable. Semi-colon separated. – MattP Sep 20 '15 at 23:12
  • @MattP it doesnt let me type on there but I can delete. its really weird.. – BuzzLightYear Sep 20 '15 at 23:22
  • copy paste ? after all it is good to have first backed up everything that is there , copy it and toss in in a notepad for future referance. Ctrl-C Ctrl-V when all else fails do it direct in the registry HKEY_CURRENT_USER\Environment & HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment . which may toss a error if you do not have permission or a GPO is blocking you (providing more clues). Or a AntiVirus programs safety stuff is blocking everyone and everything. – Psycogeek Sep 21 '15 at 5:23
  • It is odd... Two other possibilities: Windows files or Registry entries are damaged, or the TrustedInstaller owns the variable in the Registry. You can change PATH by editing the Registry directly: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment, and you might need to take ownership. BTW, have any Group Policy changes been made? – DrMoishe Pippik Sep 21 '15 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.