2

I have three years old HP Laptop (HP CQ42). It was working just fine till yesterday. Yesterday, I left my laptop turned on for about half an hour. When I came back, there was no display. Only "Caps Lock LED" was blinking and "WI-FI LED" was red. Now, when I try to turn it on, I can hear the fan/HDD spinning but there is no display (only blinking Caps Lock LED and red WI-FI LED). I tried to turn on my laptop with battery and without battery (on ac main) but no luck. I also, tried to reset BIOS by taking the battery out and pressing power button for 30 seconds. Still my laptop is not working. Is my motherboard dead? Please help.

closed as too broad by Máté Juhász, DavidPostill, fixer1234, Run5k, music2myear Mar 7 '17 at 17:46

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I would look here at HP's listing of error lights. The frequency of error lights will help pinpoint the problem. – N. Greene Sep 21 '15 at 13:54
  • Hi - the caps lock blinking and the red wifi led indicates a BIOS corruption. Had a similar experience yesterday and managed to "unbrick" the laptop by taking out the battery plus disconnecting the cmos battery for a couple of hours. After reassembly, the bios default settings are loaded and laptop should be fully working again... from what you write it seems you did not disconnect the cmos battery for the bios... – Jim Nielsen Sep 21 '15 at 22:04
  • Thanks but removing CMOS battery trick didn't work for me. Could it be cold-solder (broken solder joints)? – imRen Sep 22 '15 at 7:12
0

Try following options to get rid of problem:

  1. Remove the battery and plug the charger then switch on laptop. If it successfully on then shut down laptop from start option and remove charger plug, insert battery and you are done. If it wont works dont worry you have other option too.
  2. Take a screw driver from your junk collection and remove and insert the hard disk. This one is just like refresh your memory.

So dont blame me if it doesn't work in your case. But 99% of the time I am sure this will works.

-2

i have noticed that the problem is caused by a corrupted bios bin file and you need to desolder your bios and reprogram it or completely replace it with a new one. 2: the problem could also be a faulty display chip and in this case you have to reflow the chip or completely remove it and put a new one though this option requires expertise and specilised equipment like bga machine to do the job

Not the answer you're looking for? Browse other questions tagged or ask your own question.