0

Install with media from MS MCT Win10pro x64 from a SD-Card slot. Did a fresh GPT partitioning of 128 GB SSD as from Win10´s choice. after the first reboot it stucks at the blue windows logo, but before Windows is actually booting (so not safe mode/logging of drivers).

Now the strange thing: When I plug in a USB stick or SD card the installed Windows 10 boots again! not every time but most times. what the heck?? Any idea? I'm quite lost.

(I must admit that the device is a MBA 2011 which isn't supported by Apple.)

C:\Windows\system32>bcdedit

Windows-Start-Manager
---------------------
Bezeichner              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  en-us
inherit                 {globalsettings}
default                 {current}
resumeobject            {a569a3fb-603c-11e5-9ef2-8784ae1558dd}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 0

Windows-Startladeprogramm
-------------------------
Bezeichner              {current}
device                  partition=C:
path                    \Windows\system32\winload.efi
description             Windows 10
locale                  en-us
inherit                 {bootloadersettings}
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {a569a3fb-603c-11e5-9ef2-8784ae1558dd}
nx                      OptIn
bootmenupolicy          Standard

--------------------------------

DISKPART> list disk

  Datenträger ###  Status         Größe    Frei     Dyn  GPT
  ---------------  -------------  -------  -------  ---  ---
* Datenträger 0    Online          113 GB      0 B        *
  Datenträger 1    Online           14 GB      0 B

DISKPART> list part

  Partition ###  Typ               Größe    Offset
  -------------  ----------------  -------  -------
  Partition 1    Wiederherstellun   450 MB  1024 KB
  Partition 2    System             100 MB   451 MB
  Partition 3    Reserviert          16 MB   551 MB
  Partition 4    Primär             112 GB   567 MB

DISKPART> list vol

  Volume ###  Bst  Bezeichnung  DS     Typ         Größe    Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     C   MacbookC     NTFS   Partition    112 GB  Fehlerfre  Startpar
  Volume 1         Wiederherst  NTFS   Partition    450 MB  Fehlerfre  Versteck
  Volume 2                      FAT32  Partition    100 MB  Fehlerfre  System
  Volume 3     D                       Wechselmed      0 B  Kein Medi

0

I just forced Bootcamp Setup to run though the video driver does not work (need to RDP and use generic driver).

And the Boot partition selection of that tool did it make work. I have no clue why, because BCD and Partitions were unmodified, I double checked that. It seems that this Apple tool was able to modify a pointer to the right partition inside the UEFI firmware that was unaccessible before??!

please share similar experiences before I close the question. thanks.

  • note: the problem came back, when I deactivate the built in SD card reader (while debugging the rest of the system) – Falco Alexander Sep 21 '15 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.