26

I want to turn off spelling and grammar checking in Onenote on Windows 10. It is the OneNote which is pre-installed on Windows 10, not Office OnenNote.

I followed How to disable auto-correct and highlighted misspelled words in Windows 10, but the app is still showing grammar mistakes.

Please help me completely turn off the spelling and grammar checking.

  • 2
    I would suggest revisiting the accepted answer on this topic. Currently you are indeed able to turn off Spelling Checks in the OneNote app for Windows 10. – Michael Frank Jul 26 '17 at 9:16

11 Answers 11

9

You can't. From a good article:

Note also doesn't respond to the Windows 10 Spelling feature. However, OneNote doesn't even have options to control spelling.

Another reason why I've given up on MS completely.

UPDATE: This has been changed in newer version. See this answer

  • 4
    Please see Siva Lokam's answer, this seems to have been fixed in OneNote 2016. – The Vivandiere Mar 15 '17 at 21:18
  • 3
    It's also in OneNote 2013... – tplive May 24 '17 at 8:46
59

For disabling spelling and grammar errors, follow these steps:

  1. Go to Review tab → LanguageLanguage preferences in OneNote from the top ribbon.
  2. OneNote options window will appear, go to Proofing, third from top, you can see the options on the right side.
  3. Click Hide Spelling and grammar errors.
  4. Restart OneNote.

It will disable all the spelling mistakes.

  • 2
    Worked... Needs more upvotes.... Should be marked as the answer. – The Vivandiere Mar 15 '17 at 21:19
  • I don't see "Review Panel" on the top ribbon. The only ribbon tabs are "Home", "Insert", "Draw", and "View". I'm using the OneNote App for Windows 10, as shown on this blog post that distinguishes the versions of OneNote. – dinosaur Apr 13 '17 at 23:42
  • I downloaded the 2016 windows desktop version of OneNote from here and stopped using the OneNote app that came with windows 10. – dinosaur Apr 13 '17 at 23:59
  • This works, however don't ever try searching for correct language by typing its initials letters - it will apparently start new note within your current notebook :D So much fail... BTW. didn't notice restart being needed after changing currently used language – SOReader Jun 28 '17 at 20:54
3

OneNote 2016 is styled like Office apps. It has Options on the File tab, and this includes Proofing. And it works.

  • Yeah, but he might like to...You don't have to buy Office... – John White Jan 11 '17 at 12:31
  • 1
    Please read the question again carefully. Your answer does not answer the original question. – DavidPostill Jan 26 '17 at 9:28
  • 2
    This answer is still valid for other users who will find this article that are using 2016. Take it easy guys. – jkdba Apr 7 '17 at 18:50
3

I finally managed to get rid of this maddeningly annoying difficulty, i.e. not being able to disable proofing in the OneNote app for Windows 10, simply by updating the app.

The new version lets you "Hide spelling errors" under Settings → Options.

You can update OneNote via the Windows App Store.

  • I can confirm this works for the OneNote app for Windows 10 (Version 17). – Michael Frank Jul 26 '17 at 9:05
0
  1. Goto: Review >> Language >> Language Preferences >> Proofing (on pop up)
  2. Unselect "Check spelling as you type" and "Check grammar with spelling".
  3. Click Ok.
  4. Here's the screenshot for reference: enter image description here

Next time whenever you want to check the spelling explicitly select the text and press - F7.

  • How can I do the inverse of this. Check spelling always except sometimes select a portion of text and ignore spell checking, just for this selected text? – James Wierzba Jan 29 '18 at 19:12
0

For Mac Users :

OneNote >> Preferences >> Spelling >> 'Uncheck both checkboxes'

OneNote is not a tab in One Note itself, don't try to find it beside home | insert | draw| view. See the top mac window pane

-1

In the one note desktop app there is no way to disable the spell check. But you could log into your acccount at One Note Online. Here they ignore spelling mistakes. But you need to sync you desktop app to access the same from One Note Online.

-1

SOLUTION APRIL 2017 (NOT 2016 VERSION; NOT BETA):

Top-left menu-button>Settings>Options>Proofing{"Hide spelling errors"}>Off>restart Onenote>voilà!

(...the description is illogical compared to the function, and should have been "show spelling errors" to make sense.)

-1

I was able to remove all the highlighted recommendations by unchecking Check Spelling As You Type.

  • That option is not available in the version of OneNote OP is using. – music2myear Jul 27 '17 at 21:18
-2

It is possible. I just did it.

  1. Simply follow “How to disable auto-correct and highlighted misspelled words in Windows 10

  2. De-select “Highlight misspelled words”

  3. But then you must restart OneNote for it to take effect.

Re-open OneNote. It will no longer highlight misspelled words. I like OneNote because it's less buggy than other note synchronizers, while staying simple like Notepad.

  • The OP said he had already followed the instructions in that link and they didn't work. – Burgi May 8 '16 at 17:44
  • 2
    Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. – DavidPostill May 15 '16 at 9:16
  • This does not work. – Frederik Struck-Schøning Jul 27 '16 at 8:16
-2

This is so easy, but took me forever to figure out! Go to

File > Options > Proofing > Hide spelling and grammar errors.

  • 4
    OP said they already checked that setting in their question. – cascer1 Oct 4 '16 at 8:48

protected by Community Jan 16 '18 at 14:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.