2

I have recently had an issue with the Armenian alphabet not properly displaying on pages that do not use the default browser font. However, I have no idea what is causing this issue. Pages where the default font is used, such as Wikipedia, display the characters fine. Pages that have a set font, such as Google, display empty squares.

enter image description here

enter image description here

It should be noted that I have set all Armenian text to display in "Times LatArm," a font that is specifically for the Armenian alphabet.

2 Answers 2

2

Disable DirectWrite.

Go to address bar and type chrome://flags/#disable-direct-write. There you will see the option to disable DirectWrite. It worked for me to display Armenian again.

0

In Google-chrome, go to more tools =>Encoding => and choose "auto detect" or "Unicode (UTF-8)". Any other browser, try setting the Encoding to Unicode-UTF8, and it should display correctly. Decades ago, a user needed to have the correct character set to display non-Latin scripts, but since Unicode, all languages can be displayed using Unicode.

1
  • I changed my encoding, but I still see empty squares. Sep 22, 2015 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.