0

I'm using Windows 10 Home parallel with Ubuntu 14.04 on Lenovo ideapad S400. Every time grub bootloader appears I'm not able to select operating system, because keyboard is not working, so it always defaultly boots into Windows.

I've tried to use an external wired USB keyboard on every possible port and also disconnect other USB devices, but no result. I've double checked that USB Legacy Support is enabled. The keyboard definitely works in BIOS, but not in grub.

Do you have any ideas how to get through this issue?

Update: I found out, that computer only responds to Ctr+Alt+Del when it's in grub.

2
  • Have you tried a PS/2 keyboard (or USB keyboard with a PS/2 adapter)?
    – fixer1234
    Sep 22, 2015 at 19:08
  • No, it's a laptop.
    – xbilek18
    Sep 22, 2015 at 22:15

1 Answer 1

0

Although some time has passed and several hints about not working keyboard in grub can be found on the web, i discovered a reason which to consider may help in some cases:

The USB keyboard may be unusuable in grub because another USB device is also plugged in which interferes whith grub keyboard usage.

For details in my case please see https://savannah.gnu.org/bugs/index.php?57010

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .