1

There's a GIF of some program on Windows 8 (e.g. Nvidia settings window where you can click Download button to go to web and download latest driver)

enter image description here

So nothing happens when clicked, the window just blinks. This happens to all programs I have, including Mozilla Thunderbird, Skype, even not programs e.g. Control Panel.

  • I tried disabling security (only Malwarebytes and Windows firewall)
  • I tried clean boot
  • I tried safe mode
  • I scanned my computer from viruses
  • I ran sfc /scannow and various dism commands
  • I ran Tweaking.com Windows Repair repair package in safe mode
  • No errors in Event Viewer
  • I do use CCleaner to clean and fix registry
  • Internet browsers like Firefox, Chrome and IE does work and open links when browsing pages, but it doesn't open any browser when clicking on a link on a non-browser program.
  • I checked my default programs set to open HTTP/HTTPs, Firefox is set to it.

I'm on win8x64 (not 8.1)

EDIT: Fun fact, so far I found only one program that opens links and it's mIRC software for IRC chatting. However at the same time other IRC software like XChat does not work.

EDIT2: Okay, narrowed down the issue. In the default programs settings I switched all links to open by default by Google Chrome from Firefox and it worked, links did open. Then I set it all back to Firefox and it doesn't work again. So it got to be Firefox issue. Firefox is my primary browser, I cannot stick with Chrome just because of this issue.

  • I did clean uninstall and delete all folders in %APPDATA% and fresh install Firefox, didn't solve.
  • I wonder if the path it has stored for Firefox is somehow incorrect? Is there an option to specifically select firefox.exe via some dialog box? – miyalys Sep 23 '15 at 11:26
0

Seems like a registry issue and you may have to dig too deep to get it done.

I do use CCleaner to clean and fix registry

Registry cleaners often have unwanted results, and that may be the case here. You should often back-up your registry if you go down this way.

However, there's a possible workaround if you want to stick with Firefox (and stick you should!) in that you can use the developer edition instead: https://www.mozilla.org/en-US/firefox/developer/

If you'd rather the UI of the regular Firefox, there's an option in about:settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.