My computer is running Windows 10. I have kept Windows defender on as it was light weight and just worked in past versions of Windows.

However, in Windows 10.. I find that for about 5-10 minutes of resuming from hibernate, multiple msmpeng.exe processes cause disk usage to spike to about 100%. Obviously, its running a scan.

How can I stop the Windows defender process from running immediately after powering on my computer? Can I keep real time scanning on and still delay the rage inducing behaviour caused by Windows Defender?

  • 2
    Do you have Steam installed on your computer? – EntMobSec Sep 23 '15 at 15:58
  • This may be normal if the scheduled scan task has been missed, check Control Panel>Admin Tools>Task Scheduler>Windows>Windows Defender, check the "Windows Defender Scheduled Scan" task settings, they may not be set for your needs. – Moab Sep 23 '15 at 21:47
  • @OfflineFiles: What has Steam have to do with it? (And how to fix it, it does??) – Protector one Aug 29 '16 at 20:09
  • It was a common issue at the time I wrote that – EntMobSec Sep 6 '16 at 11:53

To disable this behavior, try these. For some genius idea, that file is scanning itself. I am sorry but I really can't explain why is that happening. Adding it to the exclusion list, fixed for mines and for my friends. That's how I came to that conclusion. I have also experienced similar situation and this worked.

Anyway, let's fix it!

Open Task Manager, and right click the "Antimalware Service Executable" and choose open file location.

Once you opened file location, you must the copy the directory from the address bar.

Now, go to Windows Defender , go to Settings > Excluded files and locations.

In first box, paste the path and click Add The path will show up on the second box Save changes and your problem must be fixed. Please note that this procedure is a workaround, it reduces the protection, it excludes scanning the mentioned path. If that's not a problem, go ahead and give it a try.

Regards.

  • How do you know its scanning itself? – Moab Sep 23 '15 at 21:52
  • @Moab, adding the exclusion fixed for mines and for my friends. That's how I came to that conclusion. – Akshay Sep 24 '15 at 10:01
  • Ah, add this info to your answer please. – Moab Sep 24 '15 at 11:46
  • @AkshayC.S. Thanks, this help me. – John Hpa Aug 19 '16 at 3:01
  • Should this bug be reported to Microsoft? – TopHatProductions115 Dec 29 '16 at 19:20

I went into widows defender settings and excluded C Drive. My copy / paste operation went from around 8.5 minutes for 121 Mb to 1.25 minutes Copy operations were in the 1.5 - 4Mbps range, not the 100kbps range.

There is an app to disable Windows defender on windows 10, here. I have no experience of this app.

http://winaero.com/blog/nodefender-disable-windows-defender-in-windows-10-with-few-clicks/

  • 2
    This solution seems extremely unsafe as most viruses will install on your C: drive. Excluding your drive from Windows Defender would allow lots of security issues unless you run another antivirus software – Aserre Sep 27 '16 at 9:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.