0

I have a ubuntu 14.04 server and for some reason the first(or two) time(s) I connect to telnet, ssh, or ping from the server to say... bing it times out. Here is my output:

root@server:~# ping google.com -c10
PING google.com (216.58.219.142) 56(84) bytes of data.
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=3 ttl=59 time=8.21 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=4 ttl=59 time=8.16 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=5 ttl=59 time=8.26 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=6 ttl=59 time=9.07 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=7 ttl=59 time=8.15 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=8 ttl=59 time=8.21 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=9 ttl=59 time=8.26 ms
64 bytes from mia07s26-in-f14.1e100.net (216.58.219.142): icmp_seq=10 ttl=59 time=8.19 ms

--- google.com ping statistics ---
10 packets transmitted, 8 received, 20% packet loss, time 23059ms
rtt min/avg/max/mdev = 8.154/8.316/9.075/0.309 ms

The VPS maintains its not on their end even though I haven't changed anything applicable. I disabled the firewall as a test. Here is the output for the NS settings:

root@server:~# cat /etc/resolv.conf
# Generated by SolusVM
nameserver 8.8.8.8
nameserver 8.8.4.4root@server:~#

And here is the output of ifconfig

eth0      Link encap:Ethernet  HWaddr 00:16:3c:a0:dc:a5
        (removed IP address here)
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42002 errors:0 dropped:22 overruns:0 frame:0
          TX packets:11949 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2016273 (2.0 MB)  TX bytes:2282576 (2.2 MB)

eth0:0    Link encap:Ethernet  HWaddr 00:16:3c:a0:dc:a5
          (removed second ip address here)
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1876 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1876 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:492835 (492.8 KB)  TX bytes:492835 (492.8 KB)

I am out of ideas to try. I did a netstat to look for the connection when I tried to connect and it didn't show anything. If the firewall is disabled what else aside from their network could be blocking it and is there a tool/log I can use to figure it out?

1

Open two terminals on your VM, they may well be two ssh sessions. On one of them, issue as sudo the following commands

       apt-get update
       apt-get install tcpdump
       tcpdump -i eth0 -n icmp

On the other terminal issue the usual

       ping -c3 8.8.8.8

In the first terminal you should see the three pings, if it is not your fault, otherwise you should see only one.

This will improve your chances of diagnosing this issue.

Edit:

After what you said in your reply, you should install mtr, and give the command

           mtr 8.8.8.8

you will see where the ping packets are dropped.

| improve this answer | |
  • Showed three pings to google from tcpdump, the ping shows 100% packet loss this time. What exactly does this prove? Technically couldn't I be blocking the ping responses? – FrostyFire Sep 23 '15 at 18:26
  • @JABFreeware If you have seen the pings on tcpdump, then no you aren't blocking them; tcpdump is the last program before the packets leave your NIC. Also, no you are not blocking the replies, tcpdump is the first program the packets meet when they enter your pc. On the way out, the packets first cross the firewall, then tcpdump. On the way in, the packets first traverse tcpdump, then the firewall. Hence you are not blocking pings, someone else is (your ISP)? Install mtr, give the command mtr 8.8.8.8, you will see where ping packets are dropped. See my edit. – MariusMatutiae Sep 23 '15 at 21:19
  • Thanks I will try that! Awesome info, didn't know any of these tools. :) I'll give it a shot. – FrostyFire Sep 23 '15 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.