3

I'm trying to remove write protection from my 32 GB microSD from QUMOX.

It worked till yesterday, when my phone said "SD card is damaged, try to format". So I did, no luck.

Every time I try to write files, delete / format partitions, delete files, or any other write operation, things do not change.

I tried:

  • moving the writeonly tab on the adapter
  • using diskpart to remove readonly
  • registry entry StorageDevices, couldn't find it
  • switching adapters, nothing changed
  • used MiniTool PartitionWizard for a "Surface Test", read is 100% fine
  • used SD Formatter from SD Assosciation, says "disable write protection"

Any clues on why this happened? My SD card is pretty young, so I believe it's not because of the high use of it, the only use I can think of is adding some music once a month and using CCleaner for Android once a week.

The last time I formatted it made it undetectable by windows explorer (and thus any library depending on it), even if specialised software (i.e. Disk Management, KDEPartitionManager, MTPartitionWizard) still detects the disk and its partition, with all the files intact.

I'd also like to point that formatted my microSD three or four times, some on Windows, some on Linux, is it possible that the Protected Area got corrupt and OSs can't get code to write on it?

Thanks in advance.

  • Your phone takes the MicroSD directly without SD adapter, correct? (just in case). Im almost sure that the adapter is to blame for the write protection since MicroSD cards have no write protection tab. Probably some error happened in the phone, and then you're having trouble with the adapter. – SOMN Sep 23 '15 at 16:47
  • other microSD work correctly on both the phone and the adapter @CláudioPereira – Massimo Pesavento Sep 23 '15 at 16:56
  • 1
    Flash memory cards go into write protect mode when they fail (run out of spare blocks). It allows you to extract your data but prevents writing new information to the card. – fixer1234 Jan 15 '16 at 23:58
1

Your card may be locked via MMC write protection flag (perhaps your phone did that for some reason). Unfortunately, this cannot be fixed by a card reader which presents as a USB mass storage device (that is, most of them) If you have a Linux computer with a real SD/MMC card reader, try running

sudo sdtool /dev/mmcblk0 unlock

sdtool can be found here. There are ready to use ARM / AMD64 builds, for other platforms you'll have to build from sources.

It seems that a similar action can be performed with hdparm, but I haven't tried that personally.

| improve this answer | |
  • 1
    i need the tools, but the url show 404 – Adi Prasetyo Jun 26 at 10:16
  • @AdiPrasetyo Thanks for fixing the link for me! – Dmitry Grigoryev Jun 29 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.