0

I'm guessing this is something simple as I just started networking recently and today is my second day messing around with this switch and virtual machines. I'll include all the information I think might be relevant - if there's any more you need, please mention.

No firewalls are enabled on the virtual machines.

Subnet mask for the PC's and switch are 255.255.255.0

The cables I am using are cat5e straight through cables.

Setup:

Virtual PC 1. 192.168.2.10 --cable-- cisco 3550 switch (192.168.2.1) --cable-- Virtual PC 2. 192.168.2.11

Problem : I can't ping from PC to PC.

What I can do:

  1. Ping from PC1 to switch
  2. Ping from PC2 to switch
  3. Ping from Switch to PC1
  4. Ping from Switch to PC2

The virtual pc's are hosted using virtual box and are using NIC's I have added to PCIe slots to my desktop. I am using Tera Term to communicate via console cable to my switch.

Show running-config

hostname Switch
!
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport mode dynamic desirable
!
interface FastEthernet0/2
 switchport mode dynamic desirable
!
interface FastEthernet0/3
 switchport mode dynamic desirable
!
interface FastEthernet0/4
 switchport mode dynamic desirable
!
interface FastEthernet0/5
 switchport mode dynamic desirable
!
interface FastEthernet0/6
 switchport mode dynamic desirable
!
interface FastEthernet0/7
 switchport mode access
!
interface FastEthernet0/8
 switchport mode access
!
interface FastEthernet0/9
 switchport mode dynamic desirable
!
interface FastEthernet0/10
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
!
interface FastEthernet0/12
 switchport mode dynamic desirable
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
 switchport mode dynamic desirable
!
interface FastEthernet0/23
 switchport mode dynamic desirable
!
interface FastEthernet0/24
 switchport mode dynamic desirable
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
line vty 5 15
!
!
end

Show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gi0/1, Gi0/2

EDIT: I forgot to mention the error I get from the ping is 'Destination host unreachable'.

Additional required information will be posted beyond this point

Show ip interface brief Pretty obvious from this (that i forgot to mention) active ports for PC1 and PC2 are fa0/7 and fa0/8 respectively.

Interface                  IP-Address      OK? Method Status                Protocol
Vlan1                      192.168.2.1     YES manual up                    up
FastEthernet0/1            unassigned      YES unset  down                  down
FastEthernet0/2            unassigned      YES unset  down                  down
FastEthernet0/3            unassigned      YES unset  down                  down
FastEthernet0/4            unassigned      YES unset  down                  down
FastEthernet0/5            unassigned      YES unset  down                  down
FastEthernet0/6            unassigned      YES unset  down                  down
FastEthernet0/7            unassigned      YES unset  up                    up
FastEthernet0/8            unassigned      YES unset  up                    up
FastEthernet0/9            unassigned      YES unset  down                  down
FastEthernet0/10           unassigned      YES unset  down                  down
FastEthernet0/11           unassigned      YES unset  down                  down
FastEthernet0/12           unassigned      YES unset  down                  down
FastEthernet0/13           unassigned      YES unset  down                  down
FastEthernet0/14           unassigned      YES unset  down                  down
FastEthernet0/15           unassigned      YES unset  down                  down
FastEthernet0/16           unassigned      YES unset  down                  down
FastEthernet0/17           unassigned      YES unset  down                  down
FastEthernet0/18           unassigned      YES unset  down                  down
FastEthernet0/19           unassigned      YES unset  down                  down
FastEthernet0/20           unassigned      YES unset  down                  down
FastEthernet0/21           unassigned      YES unset  down                  down
FastEthernet0/22           unassigned      YES unset  down                  down
FastEthernet0/23           unassigned      YES unset  down                  down
FastEthernet0/24           unassigned      YES unset  down                  down
GigabitEthernet0/1         unassigned      YES unset  down                  down
GigabitEthernet0/2         unassigned      YES unset  down                  down
3
  • Could you include the output of show ip interface brief?
    – D34DM347
    Sep 23, 2015 at 16:36
  • @D34DM347 added
    – Genome314
    Sep 23, 2015 at 16:41
  • What are the IPs of the host machines? The virtual machines are configured as bridge or NAT?
    – jcbermu
    Sep 24, 2015 at 9:34

1 Answer 1

0

It turned out the problem is with virtualbox.

I created a clone of one virtual machine and as a result the MAC address was not unique. Simply changing the MAC address cleared up the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.