Windows Update installed the latest set of fixes on my computer and requested a restart.

The computer has been stuck at the restarting screen for several hours. Even after a cold reset, the restarting screen is always displayed.

Ctrl Alt Del has no effect. The Windows boot menu (F8) is not even accessible after a BIOS cold start.

How can I fix this situation?


6 Answers 6


Useful steps (always good to check first):

  • Disconnect peripherals and cold restart.
  • Turn off computer, disconnect power cord and restart after a few minutes.

Solution without using a recovery disk:

  1. Restart computer and press F8 several times to enter Safe Boot Menu. If F8 key has no effect, force-restart your computer 5 times.
  2. Select Troubleshoot > Advanced Options > System Restore.
  3. Select a good known restore point and click Restore.

Solution using a recovery disk:

  1. Plug an empty USB flash drive (> 4 GB) into a healthy computer.
  2. Prepare a recovery disk using Microsoft Media Creation Tool [1].
  3. Plug the USB drive into the frozen computer.
  4. You may have to tell the BIOS to boot from USB disk.
  5. Restart computer. Windows Setup will show up from USB drive.
  6. Select your language, keyboard layout and click Next.
  7. Click "Repair Windows" (but not "Install Windows").
  8. Select Troubleshoot > Advanced Options > System Restore.
  9. Select a good known restore point and click Restore.

[1] https://www.microsoft.com/en-us/software-download/windows10

  • What is meant by "Close computer" in the 2nd bullet item? Close the door, if the computer has a door? Or "close" the software by forcibly powering it down? Commented Apr 16, 2017 at 21:02
  • Marnix > You're right, I should have said shut down or turn off. Answer corrected!
    – rjobidon
    Commented Apr 18, 2017 at 2:37

I had Windows 2012 R2 stuck at reboot with the spinner spinning with the screen pictured in the question. The way I got into this state was I clicked the Reboot/Restart button in Windows Update and then responded “Yes” to the prompt of whether it was OK to restart even though other users were logged in. Then it displayed the “Restarting” screen forever. I think it was confused, it was supposed to show me if I wanted to close my apps first before proceeding but was instead showing the Rebooting screen forever.

I was accessing the server via mstsc (RDP), so to get out of this situation, I pressed ctrl+alt+end (which is like pressing ctrl+alt+del on the remote computer). This came up with the security options display. I then clicked on “Sign out”. This caused the screen to display “Signing out…” for a few seconds before showing me the prompt of whether or not I wanted to save my files or Restart anyway. I clicked Restart anyway to proceed.

After that, Server signed me out. When I logged back in, I saw that the server uptime was still more than a couple minutes. So I initiated a reboot again and it finally went -_-.

  • was not aware of CTRL + ALT + END combination. This saved me!
    – rh0x
    Commented Aug 26, 2020 at 15:03
  • There are files that I did not save. The CTRL + ALT + END solution worked for me.
    – selami
    Commented Oct 16, 2021 at 4:46

Nothing worked on my computer. Just had the little circle going around. Control Alt delete did nothing. I pushed the power button and it seemed to shut down but when restarting it just came back, that little circle with the word "restarting ". I shut down again then pulled the battery. Put the battery back in and it started normally.

  • 1
    Sounds like when you thought you were powering the computer off you were actually “sleep”ing it. Most laptops let you hold the power button down for 5 seconds to do a hard power off (which is basically equivalent to pulling the battery but a little bit “kinder” to the device).
    – binki
    Commented Aug 16, 2017 at 21:11
  • I had the same thing happening on a Surface Laptop. Long press Power would black out the screen but then it came back on the restarting screen. What did work eventually was to hold down Power + Volume Up.
    – GFK
    Commented Jan 10, 2020 at 11:04

This is a simple fix for this problem, perhaps not typical, but my Shift key was stuck down and I could not reboot or get through the start Ctrl+alt+delete. I unstuck the Shift key and my desktop reappeared.


Turn off laptop, and take out battery for a few seconds. And then put back in and turn on. And will start up normally ☺

  • 2
    Can you explain why and if possible cite any source for this?
    – pulsejet
    Commented Feb 1, 2017 at 12:37

I Had the same situation with server 2012 doing a reboot remotely stuck for 24 Hours saying restarting But I could login as a different administrative user & restart from that user (Strange)

Logical Step

  • How did you login when the system was at the restarting screen?  Please do not respond in comments; edit your answer to make it clearer and more complete. Commented Jul 7, 2019 at 3:11
  • 1
    I logged on remotely using a different admin user Commented Jul 8, 2019 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .