I upgraded my windows 7 to Windows 10 Pro.

I'm using a Sony Vaio VPCSA23GX (I've read the articles of delayed driver support for Vaios) With an Intel Core i5-2410M CPU. My Bios is an InsydeH20 Rev. 3.5 and the Bios Version is R1031H4 (This bios seems minimal)

Once updated, I did a clean install. Everything seemed to be going well.

In my laptop I have two display adapters, one is the Intel(R) HD Graphics 3000 and the other is an AMD Radeon HD 6630M.

I could care less about the the Intel HD graphics and wouldn't mind making it disappear forever. Which I tried to do through device manager and through the "Uninstall program" way. It just keeps coming back like a virus or something! Also just disabling it didn't seem to do anything either.

My AMD card drivers are up to date using the amd-catalyst-15.7.1-win10-64bit.

So what this boils down to, is can I make my AMD display adapter my primary one, permanently if need be. Or just a way to switch to using it instead of the intel graphics.

I'm not afraid to go into the registry if that is what it will take to get the job done also.

I also noticed in my AMD Catalyst Control Center, it seems I'm missing options, like power/gaming.

Thanks in advance!

  • Disabled, uninstalled or not, is your AMD card being used as default or is it being ignored for the Intel? If the AMD card is being set as default and used-- and if there's no BIOS option to disable the Intel-- then I don't see why it's a problem.
    – Insane
    Sep 25, 2015 at 2:51
  • It's not being set to default (not that I know of at least) and there is no option in the BIOS to set what I want as my default card. Is there any other way to do this task?
    – Timmy
    Sep 25, 2015 at 3:05
  • How do you know it's not? Press Win + R and type msinfo32 then under components and display, what's the name of the graphics adapter you see?
    – Insane
    Sep 25, 2015 at 3:21
  • 1
    msinfo32 shows both graphics adapter under Componenet->Display. But when launching a game it acts like it's running off the intel 3000. I found that InsydeH20 BIOS "hides" settings also making their BIOS pretty limited to users.
    – Timmy
    Sep 25, 2015 at 4:27

1 Answer 1


Ok, I know this question is old, so you've probably fixed this by now, but I'll answer anyway to help anyone who stumbles upon this. I am by no means an expert on this, but I have set up multi-gpu laptops before, so this is my two cents.

Basically, you DON'T Want the AMD card as your primary.

Because GPUs are relatively high power devices, and laptops have batteries, most use the low power Intel chip for basic stuff like browsing the web, of which it is more than capable. They will then switch over to using the more powerful GPU when a game or other demanding program starts up.

You may notice in some games (Bathesda and Valve titles tend to do this, but I've seen it in several games) under the graphics section it will say it is running on the Intel card, ignore this, these multi-gpu setups confuse games. If you want to know what GPU a game ins running on, just look at its performance, the Intel chip will just fall over.

There is a way with NVIDIA cards to force a specific program to run on either GPU. I'm sure there must be an option for AMD cards too.

Usually the laptop will switch to only using the Intel chip if it has no power connection, this can be switched off by going to power settings and changing the power plan to high performance.

I can't think of any times where somehow disabling this feature would be beneficial, If you need the power, it will provide it.

Hope this helped someone

  • This specific laptop actually has a physical switch that switches the graphics, it isn't software based switching like most laptops. So until drivers are released (Which may be never for this model since Sony sold Vaio) I don't know if there is a solution. There was no way to force a specific program on the graphics card since it was never "electrically active" from the physical switch. I just rolled back to windows 7 and am still enjoying it as is.
    – Timmy
    Nov 17, 2015 at 13:22
  • Ok, I'll give you that one, I'd never even heard of that being done before. Nov 18, 2015 at 14:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .