0

I'm very new to Linux, and I'm currently experimenting with it and several services in order to familiarize myself to it. I've installed vsftpd to access the machine over ftp however I'm getting the error below:

>>>  USER username
<<<  331 Please specify the password.

>>>  PASS ***********
<<<  500 OOPS: cannot change directory:/home/username

  --> FTP reconnected
>>>  PWD
<<<  500 OOPS: priv_sock_get_cmd
Error EElFTPSUnacceptedReplyError: Unaccepted server reply (error code is 500) 

I've confirmed port 21 is open. The versions being used are vsftpd v. 2.2.2 on centos 6.8.

Help is greatly appreciated.

Many thanks in advance,

J

  • See askubuntu.com/q/174235/280048 – Martin Prikryl Sep 25 '15 at 7:30
  • @MartinPrikryl Thanks for your reply. I've ensured that the user 'username' and the group he belongs to has full access (CHMOD 777), however I still get the same error. – joebegborg07 Sep 25 '15 at 7:34
0

Ok I solved this by disabling SELinux, which from what I can understand is similar to what UAC is to windows.

This was achieved by checking the status and determined that it was in enforcing mode:

sestatus

Once that was determined, I changed this to permissive through the following command:

setenforce 0

Restarted vsftpd service using service vsftpd restart and was able to access the machine over ftp.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.